Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

238 Questions View all

During startup I see a flashing question mark.No hard disk

I have a problem with my iMac.During startup I see a flashing question mark.The problem occurs frequently so I decided to reinstal my system software,Mac OS X,but I cant't.In the pane where I'm prompted to select a disk,there is nothing there,no hard disk.It looks like I have a hardware problem since the drive is not even visible from within the Disk Utility application.

If I need to change the hard disk,the old one was Western Digital 500 GB, SATA/16MB, WD5000AAKS.I searched for this model,but I can't find it here in Greece,only WD5000AAKS SATA 2/32MB or SATA 3.I read on some forums that SATA2 is compatible with SATA1.What should I choose?Thank you!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

This model of iMac shipped with 3 different manufacturer of hard drives. Each different manufacturer has a specific temperature sensor cable which MUST be installed between the drive and the logic board. So if you are replacing the hard drive and it is a WD then you must have the temperature sensor cable that is for the WD only. Any SATA 3.0 Gbs 3.5" hard drive will work in this model but again it must have the matching temperature sensor cable.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Cristi will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 529