MacBook Pro 15, 2.4, A1260 not starting

MacBook Pro 15 2.4 A1260 YJX

Hi Guys,

My MacBook Pro 15 has suddenly died on me, I press the power on button and life appears as long as my finger is on the button, life is cut as soon as I take my finger off.

If I press for over 5 seconds the power light blinks and the laptop power cuts off.

The magsafe seems fine as does the battery, I m using the proper 85 watt.

I ve tried it with and without the battery, checked the ram and it beeps when there's no ram in.

I couldn't find the icon on the logic board to power on without the top case, does anyone know where it is on a MacBook Pro 15 2.4 1260? I've searched a few times using a magnifying glass!!

All help would be greatly appreciated

Many thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Apple MacBook Pro "Core 2 Duo" 2.4 15" (08) Specs

Identifiers: Early 2008 - MB133LL/A - MacBookPro4,1 - A1260 - 2198

by

Fabulous Thanks!

Thanks Mac Head, its a slightly different layout but there was enough info on the image to point me in the right direction. the solder points on mine are to the right of the Ram slots with PWR at 45o. very small I must add.

The mac showed some sign of life but not much, just half a second flash from the power light followed by a quick spin from the fans.

As it didn't start from the logic board should I fear the worst or would there be any other hoops to jump.

I don't know if this is connected but I remember the night before it stopped running that there was some slight disturbance in on my secondary screen that I was using with the mac, it looked a bit like heat rising from a hot surface, but just ever so slightly, I thought it was odd but I didn't really think much more about it, as I say it was very slight.

My mac has the NVIDIA Geforce8600M on board but I kind of ruled that out as being a problem as the symptoms of my mac seem so catastrophic.

Thanks again

by

Now I've opened it up, disconnected everything from the logic board except the left I\O. No results.

I disconnected the I/O and reconnected it now nothing happens at all.

just a faint glow on the charger light which is blinking very faintly.

The battery shows 5 lights and nothing at all happens when I re-install it.

Any ideas ? I'm losing hope on this one.

by

Hi Richard:

Did you get any further on this Laptop? I received the exact same model (YJX) yesterday and it has the exact same symptoms as yours. I also tried to isolate the motherboard by disconnecting the display, wireless, hard drive, optical drive, keyboard and trackpad. Still doesn't stay running. I did find an extended warranty on this model, but not sure if they would consider it the same as it doesn't stay running. It does have no video though. Ray http://support.apple.com/kb/ts2377

by

Hi Ray, No joy yet. I had an appointment at the Genius Bar but I embarrassingly took the wrong mac with me!!!!! Don't ask me how I done that, perhaps I need a doctor.

However the only good news is that I took it all apart again and now the mag safe works, I m guessing I didn't connect it back securely the last time.

But it still won't power up.

Thanks again Mac Head. It won't power up from the opitcal drive and I tried it with various ram configurations, it did beep without ram though if that means anything.

Thanks all.

I'll head back to the genius Bar and no doubt they will will tell me the Logic Board has failed. would be lovely if its the NVIDIA as they said they would replace it if it was.

Just another thought, is there an interior fuse in this laptop that could cause the same symptoms ?

by

Add a comment

1 Answer

Chosen Solution

See Where are the power pads located on the logic board? Answer

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 0

Comments:

If you can't boot from the optical drive (the machine won't keep running) it's the logic board. At this point you have nothing to loose so look over the board for corrosion, broken swollen parts (if you find any corrosion clean it with dielectric contact cleaner), renew the Thermal Paste, on the heat sink, try no RAM boot to see if the EFI gives you the no RAM chimes. IF IT DOESN"T (or you find broken, swollen parts) the boards crap. If it does try ONE RAM chip. Good Luck,

by

Add a comment

Add your answer

Richard will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 8

All Time: 3,923