Display assembly from A1260 to A1226

Hi everyone !

Can I use a display assembly (including inverter, Airport antena, hinges, casing, data display cable...) from a macbook pro A1260 to my A1226 ??

I can't find a 100% sure answer... :)

It's seems ok for me, but on the website I can see there is 2 models .... help me !

Thanks a lot !

new_blues

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

5 Answers

Chosen Solution

Funny you should ask, I literally just ordered an a1260 display assembly yesterday for my a1226, it's on rush shipping so I'll update this post after I try it. I already replaced the top case (part that contains the keyboard and trackpad) for it with one from an a1260 which works flawlessly, I even got the multitouch features and new function buttons along with it, worked as soon as I installed it, no fiddling. These two models seem to share a lot of parts, so I'm crossing my fingers along with you.

BTW for anyone else reading, my a1226 took a spill down some stairs, the screen actually tore off of the laptop, IE the hinge is still attached but the lcd and back cover are completely gone, case bent up, ribbon cables spilling out of it, but I plug it into an external monitor and it hasn't missed a beat. I'm posting right now on half of a macbook pro haha. These old macbook pros are tanks!

Update

So I installed it, and it's a little finicky. I saw a few other sources that say it should work, but mine only works once you connect and disconnect an external display, otherwise the display isn't detected. I may have damaged something when I installed it, but I'm still fooling with it. Search for the display assembly on here, there's some more info. If I figure out what is going on I'll let you know.

Was this answer helpful?

Score 1

Comments:

Hey !

Thanks for ur answer.

Hope it will work for you.... and for me me :)

Let me know !

Cheers

by

hum.... that's really weird, and doesn't reassure me. I'll check if I found something on the net, I'll let you know !

by

Add a comment

Maybe it's obvious, but did you try resetting your PRAM ad NVRAM ??

Someone with almost the same problem as you solved it with this solution.

Let me know

Was this answer helpful?

Score 0
Add a comment

I ended up deleting a couple of plist files as suggested here (https://discussions.apple.com/thread/209...) and everything works fine now! Not sure if that's what fixed it, it seems odd but I'm not complaining. The moral of the story is it should work.

Was this answer helpful?

Score 0
Add a comment

Ok , thanks for sharing that.

Good news btw :)

I'll update the post after I try my self too.

Was this answer helpful?

Score 0
Add a comment

Ok, I've just done it and... it works perfectly !!

I changed the entire display assembly, the optical drive and the top case, and everything work ! All the parts was coming from a A1260.

Hope this post will help .

bye

Was this answer helpful?

Score 0
Add a comment

Add your answer

newblues will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 929