Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

838 Questions View all

iPod classic 160gb (slim) stuck in restore loop.

Wondering if anyone can help me with this one, i have an iPod classic 160gb slim which has had:

  • a new logic board - running firmware 2.0.4 p/n 820-2437-a
  • a new hard drive - 160gb toshiba mk8022

After fitting these parts i cannot get the unit to restore, so have changed the hard drive ribbon cable. but it is still the same. It goes through the motions of a restore but the pops back up in iTunes again straight away saying it is in recovery mode.

The original ribbon cable has the following part number: 821-0728-01

but i cannot find a replacement for this so have tried both:

632-0337, 821-0386-03

And I've read on here that the ribbons should be interchangeable. I'm at a loss, anyone got any ideas?

Thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

illPod, I previously have had trouble similar to what you are experiencing. My mistake was that I originally had a Toshiba drive and replaced it with a Hitachi. The ribbon cables seem to be different for the two. You might start there. I would go ahead and purchase a new one. Previously , even so I had the right cable, a new cable fixed problems like that as well.The other thing I would invest in is a USB-to-ZIF adapter and see if you can access to HDD separate from your iPod. That way you can try and format it and you will know if,or if not, your drive is the part that causes the error. Of course make sure that your connector is clean and that the clip to hold the cable down is working. try to place your iPod in Disk mode and diagnostics mode and see if it responds the way it is supposed to. If your HDD checks out, your cable is replaced and you still have the same issue, try and exchange the logic board. See if the vendor would replace it for another one. Hope this helps, good luck.

Was this answer helpful?

Score 0

Comments:

Hi oldturkey,

Thanks for your swift response.

I should have mentioned i have checked that the hard drive is working with a zif to usb adapter and that works fine.

I have replaced the ribbon twice but i'm unable to find anyone selling one with the exact same part number: 821-0728-01 here in the UK

This is also the second new logic board i've tried with this device. Although i think this was as a result of it having the 2.0.1 firmware rather than the 2.0.4 even though both boards were 820-2437-a

So do you think it's a logic issue? the supplier i use for these boards is usually very reliable.

by

If your HDD is functioning without the iPod and you have no problem accessing it and if your cable is ok, the only other thing would be the logic board. You could try with another firmware from here http://www.felixbruns.de/iPod/firmware/ The only other thing I noticed is that I get a return of a 80GB HDD for the MK8022.

by

yeah sorry that is my mistake, it's actually an mk1634gal. I will get another logic board ordered and let you know how i get on. thanks for the advice. I thought it must be that but thought i should check it wasn't something to do with the HD ribbon compatibility.

by

Sounds good, let us know how it is going.

by

Add a comment

Add your answer

illPod will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 18

All Time: 3,634