Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

511 Questions View all

No boot chime, no image on LCD, no image on external display

When powering on my MacBook, the power light turns on and the Superdrive and hard drive start. The screen flashes once and then goes dark. There is no boot chime and nothing else seems to be happening. The display is completely dark and blank. There are no barely visible icons or anything. I took it to the Apple store and they connected an external display to it, but there was no signal to the display. After some random fiddling (opening/closing the laptop display lid, restarting it) it magically came back to life. With the LCD working they moved the display lid back and forth and noticed the screen flickered once, but didn't continue flickering with more movement of the display. I took the laptop home and it continued working for a week, but it started rebooting itself occasionally. The rebooting usually happened when the case was lifted on the left rear side. Is this a bad inverter cable or inverter board?

Note: ABCellars' suggestion to test the RAM and RAM slots fixed my problem. See his comments inserted below machead3's answer. Thanks ABCellars! If you can post your response as an answer, I'll accept it!

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Before you call the board toast. Check the RAM and RAM slots. Take a known good stick of RAM and put it in 1 of the RAM slots. Try booting it and see what it does. Shut it down move that RAM stick to the other slot and see how the system acts. NOTE: Remove all power sources, battery and AC adapter, when uninstalling and installing the RAM, to prevent damage to the chip(s) and/or the board. I would also try booting from the OS X install disk to see if the problem exist in the preinstall environment. From the information given it didn't get a kernel panic until after the operating system is loaded.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

Sounds like it, OR might be bad data display cable... check the cables for cuts/nicks while your in there tighten the clutches (hinges). The restarts sound like shorting of the logic board... hope there's no burn marks on logic board (look using a magnifier).

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

Thanks for the suggestions! I recently tried swapping out both the display cable and the LCD inverter board and still no joy. I had already previously removed and inspected the logic board and I didn't see anything unusual. HOWEVER, after trying my replacement display cable and inverter board (and after the computer still wouldn't boot), I rechecked all connections to the logic board and after disconnecting and re-connecting the magsafe assembly cable to the logic board, the computer booted up fine although it didn't last. When I picked up the Macbook on the left rear corner, it went dark and powered off again. Unplugging and plugging in the magsafe cable again, the computer was able to boot up again. I reinstalled my old display cable and inverter board, and I could still get the computer to boot by reseating the magsafe cable in the logic board. So, I believe my problem's being caused by a flaky magsafe board assembly or a flaky magsafe cable connector on the logic board. I'll be getting a new magsafe cable assembly in a few days and I'll post an update after I try it out. Fingers crossed!

by

Power this up with the upper case off, via the power pads on the motherboard. If you can't find them let us know. Take a new pencil, eraser side down and lightly tap around on the logic board's left side. If you find an area that by doing this it causes the system to shut down - look for bad solder joints or broken traces in that area.

by

So I think I found the "power pads". There is an area near the heatsink fan labelled "PWR BTN", but there is a component soldered there that has two pads on one side and one pad on the opposite side. (I would attach a picture of the area if I could, but I don't seem to be able to here.) I'm not sure if these are in fact the "power pads" and I don't know how to power up the computer using them.

by

The picture in this link will show you where the jumper pads are on that one, they are in a slightly different place. http://i295.photobucket.com/albums/mm132...

by

I replaced the magsafe board assembly and the bottom case (the old bottom case had lost most of its structural rigidity). I tried ABCellars' suggestion to press down carefully on the logic board and still no joy.

Still, I put everything back together and screwed it all tight. I left it alone until the next day and again pressed the power button just to see what would happen. This time, the laptop booted up!

About 2 minutes after the desktop appeared, a black warning box appeared that I needed to restart my computer. After restarting (successfully again) I viewed the crash report and less than a minute later got the warning prompt to restart my computer again. The error read:

panic(cpu 0 caller 0x2ada061): "nanotime trouble 2"@/SourceCache/xnu/xnu-1054.15.3/osfmk/i386/commpage/commpage.c:505

Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

The rest was obscured by the warning message to restart.

TIA for any more suggestions on what else I can try (except replacing the logic board).

by

Show 2 more comments

Add a comment

Add your answer

Cort will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 926