This Power Mac G4 has Mirrored Drive Doors.

90 Questions View all

Compatibility with Snow Leopard

Hello guys,

You could tell me if this MAC is compatible with Snow Loepard version 10.6?

thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

No. The highest system your machine will take is 10.5.8

Was this answer helpful?

Score 3
Add a comment

Add your answer

Andres Peralta will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 745