Skip to main content

Model A1419 / EMC 2806 / Late 2014 or Mid 2015. 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (ID iMac15,1); EMC 2834 late 2015 / 3.3 or 3.5 GHz Core i5 or 4.0 GHz Core i7 (iMac17,1) All with Retina 5K displays

568 Questions View all

iMac powers up but only to sign on screen, but I cannot select start.

Late 2014 IMAC worked fine but now it powers on, goes to start but I cannot select start. Keyboard & mouse plugged in, tried bluetooth mouse just to get to start but does not connect. Is there anyway to boot up

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Do you hear the fan or startup Bong?

Just with the limited information I’m guessing the power supply has failed. But that’s just a guess! You really need to dig a bit deeper. Did you check the outlet and the power cord, try another outlet and cord. Did you have a lightning storm or other weather event that could have caused a power surge (lights flicker or anything else stop working). I would get a simple outlet checker to make sure the outlet is correctly wired. You might want to check your buildings ground and get a good surge suppressor to protect your equipment if you discover your at risk.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Kristie Mehlbaum will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 10