Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

508 Questions View all

MacBook Charges Battery, MagSafe Light works, but won't startup.

I have an original 1.83Ghz Core Duo that indicates that it is charging and fully charged, but will not boot. Attempts to reset the SMC have not solved the problem. Had been working almost perfectly for five years, and then one day, nothing.

I have tried different batteries and power adapters, and get the same result: It will not start up, but does indicate that it is charging or fully charged.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Will not start up - is pretty vague description. Help us help you. Does it chime, flash, anything on screen? Have you had it open? Has it been dropped? What does attempts to reset the SMC mean? Did you reset the SMC or not? If you did, you mean nothing changed?

by

Thanks for your reply. When I press the power button, nothing happens. No chime, nothing. I has never been opened, never dropped. I followed Apple's instructions to reset the SMC by disconnecting the power supplies and holding down the power button. I replaced the battery, and reconnected the MagSafe. Still, nothing happened when I pressed the power button.

by

Add a comment

2 Answers

Chosen Solution

At this point you have to open the top case to see if the ribbon cable to the keyboard is damaged or properly connected.

If those are not the issues It is possible to Broken keyboard ribbon connector. How to power up? bypassing the on button. Be very careful not to touch other parts/circuits when doing this.

If that fails you probably have a logic board problem.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 0
Add a comment

right answer

Was this answer helpful?

Score 0
Add a comment

Add your answer

Apple2e will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 750