Skip to main content

Repair documentation and service information for Hisense televisions.

139 Questions View all

Hisense 65H9908 picture disappears after 20 min of viewing.

TV is only 5 years old. Model 65H9908. Turn on TV works fine (audio and video) for about 20 min, then picture fades in toward the center and get audio only. Can turn off the tv, then back on, and video will return to normal for another 10min or so, then fade to black again.. Can turn off the tv and turn it back on and video will restore. IT's almost like a software bug was placed in the TV to break down at the 5 year mark to force you to buy a new one.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

@bubbajay "picture fades in toward the center" this is the part that is worrisome. It is not a common error but seems to originate either on your main board or on your panel. Check the LVDS cables going to your panel. Check for tears and corrosion. Next check for obviously overheating/damaged components on the the "long, skinny" boards that connect via multiple ribbon cables to the LCD. Those are the driver boards and the error can originate on those. The other thing to check is the memory and the processor on your main board. Check for overheating on that as well. You can always try some freeze spray and once your TV displays those symptoms, spray on the main board and see if that restores it. Try the same on your driver boards.

You do want to remove the back of your TV and post a couple of real good pictures of all of your boards with your Question. that way we can see what you see. Adding images to an existing question

Was this answer helpful?

Score 0

2 Comments:

Thank you @oldturkey03! For sure it has something to do with heat because if I leave the TV off for a significant period of time, the TV will not "fade out to black" for hours after that cooling off period. Not sure why a component would fail like that though. It's almost like there was a new firmware update that now monitors the component temps, and fails when that component reaches a certain temp, as a safety measure of some sort. The chip is obviously still functioning just fine, as is the cct board because the picture restores after cooling. So bizarre.

by

@bubbajay something like this "picture fades in toward the center" would not be in the firmware. IT's the fading that gives it away. Give it a try with the freeze spray or use a FLIR cam and see if you can detect the hot spot.

by

Add a comment

Add your answer

Bubba Jay will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 29