Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

781 Questions View all

Why wont the compter recognize the hard drive?

So 6 months ago I got the famous flashing folder. I took it in to the Apple Store and they replaced the hdd cable. Then last week the flashing folder appeared again. This time Apple told me it was the hard drive. So I bought a 320gb 7200 rpm WD Scorpio Black as computer hard drive. I installed it and Lion in. It worked for about 10 min then it froze again. I've tried resetting the PRAM and reinstalled the hard drive but still the flashing folder. What's wrong?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

also i just tried connecting my hard drive to another computer (externally) and the hard drive ran perfectly fine

but when i tried to connect the hard drive externally to my macbook pro, and running the snow leopard install disk, the message that showed up told me to force shut down the mac after about 5 min of loading

by

Thank you for letting us know about your experience with the extrernal enclosure. Have you set the jumper yet? We can't help you unless you do what we ask to solve the problem and/or narrow down the cause. Communication is also key to solving the problem. If the other machine that could find the drive in the external enclosure is an Intel based Apple/Mac: Install Snow Leopard on the new hard drive from the other machine with the drive in the external enclosure. Then try installing the hard drive in your laptop and let us know the results. If you don't set the jumper you will not get this to work. There are thousands, if not millions of WEB pages discussing this problem with Apple laptops and SATA 2 hard drives.

by

Add a comment

1 Answer

Chosen Solution

Boot to your install disk. Run disk utility from it and repair the drive. Did you set the jumpers on your hard drive to limit it to 1.5GBs prior to installing it? If you didn't, I would start by doing so. Click here, to read more about the continued SATA 2 problem in that year of MBP. Please let us know the results.

Was this answer helpful?

Score 4

Comments:

The thing is the hard drive doesn't show up in disk utility

by

Did you set the jumper on the drive to limit it to 1.5GBs prior to attempting to use disk utilities? I'd double check the drives jumper. If disk utilities is not finding it. Then reset the SMC.

by

there aren't any jumper settings to limit it to 1.5 GB/s. and i did reset the SMC but still the hard drive is not being recognized.

by

There are jumper pins right next to where the cables plug in. There is a diagram on the label of the hard drive telling the installer how to limit the hard drive to 1.5GBs. Click here, to go to the Western Digital support page on the problem you are having and the solution.

by

Add a comment

Add your answer

Kaiwen Luan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 1,741