Output/Input Error when Installing new Internal Hard drive

2.0GHz MacBook mid 2007

My Internal HD crashed a couple months ago, so I bought a WD Scorpio Blue 320gb Sata HD.

After I installed the HD, I went into the Disk Utility to try and format it and I get an input/output error (log says "error \n" ) . CAN ANYONE HELP PLZ ??

Note: I do not have the original software CD's, so I used the software disks from a friend

(she had the same issue with her Macbook *black version*, but she followed the same steps I did and it worked).

I also ran a "hardware test" and everything was fine.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Make sure your new hard drive has a GUID partition created with Disk Utility.

by lemerise

I tried the GUID partition but I still get the same error.

by Mary

Add a comment

2 Answers

Chosen Solution

Connect your macbook to your friend's macbook with a firewire cable then boot your MB while holding down the T key on your keyboard and check if your HD mount on your friend's desktop or if you can see it with Disk Utility. If so try to format and install OS with source machine.

Or remove your HD from your MB, put it in an external 2.5" sata enclosure and try to format it with your friend's macbook.

Was this answer helpful?

Score 4

Comments:

+ Along with all of lemerise's good advice, I would make sure the jumper on the drive is set for 1.5GBs and not for 3GBs.

by ABCellars

Add a comment

I bought the wrong firewire cable, so I will make sure to update the forum once I get a chance to try out your suggestion

I am not sure how to set the jumper on the drive, do you mind explaining how to do this? (this is my first time trying to repair my computer I am not very knowledgeable on the subject)

Thanks for all of the help!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Mary will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 10

All Time: 1,453