Skip to main content

A1418 / EMC 3069 / 2017 / 3.0 GHz quad-core i5, 3.4 GHz quad-core i5 or 3.6 GHz quad-core i7 Processor. Released June 8, 2017.

176 Questions View all

Accessory port issues after SSD, memory, and processor upgrade

Components were shotgun installed, as this wasn't my first iMac teardown. Running fresh install of Monterey 12.6.1, no notable issues with OS or applications.

Only problem is that no devices are sensed when connected to the thunderbolt and SD card ports (one thunderbolt port occasionally cooperates with certain devices, but only after many repeated tries). I've tried multiple fresh installs of Monterey and Big Sur and tried resetting the SMC and PRAM. System Report shows that two thunderbolt ports and an SD card port are present. USB ports work perfectly fine.

I'm about to order a new logic board as I'm convinced the accessory ports were damaged during install. Was wondering if anyone here had any advice, or if they knew what specifically on the logic board could fail that would lead to thunderbolt and SD card port failure.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Loosen the logic board screws and plug in a few cables to help you place ports more centered in the holes. I often find this fixes issues like this.

Was this answer helpful?

Score 0
Add a comment

Add your answer

David Tkac will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 9

Past 30 Days: 13

All Time: 46