After reassembling 3AXL, phone vibrates once but won't turn on

I recently tried to repair my Pixel 3A XL. Originally, the phone wouldn't charge (with a variety of chargers and outlets), but everything else seemed to be in order, so I tried replacing the charging port and battery. After reassembling it, I've been unable to turn the phone on. Strangely, when I press the power button of the phone, it immediately vibrates once, in a way that feels like the haptic feedback you'd get while typing, for example. Afterwards, nothing else happens. All this is after I have left the phone to charge for maybe an hour or so. I've also tried holding the power button down for 30 seconds at a time; nothing happens.

The new parts came from Ifixit, so I trust them. Could it be loose connections between the various ribbon cables? More generally, how can I troubleshoot this?

Follow-up: I'd like to get the phone back to working order, but I'd be willing to render it inoperable if I can grab the data off it, just in case that opens up any options for me.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment