Skip to main content

Released September 22, 2017. Model A1864, A1897. Available as GSM or CDMA / 64 or 256 GB / gold, silver, and space gray.

624 Questions View all

Unable to restore iPhone 8 Plus

I have an iPhone 8 Plus that I changed the battery in. The new battery caused it to boot loop. I put the old battery back in (80% health) and it turns on and shows the Apple logo for awhile(a minute or so) then reboots. I tried restoring it with both ITunes and 3UTools but iTunes gives error (9) and 3uTools gives the error: ERROR: Unable to receive message from FDR 01:38:31.417: ERROR: Received data timeout.

I have tried new cables and USB ports, new charging port and tried restoring in DFU mode. Any idea what is going on and how to fix it?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

Here's my take. Error 9 can be indicative of a lot of things, but it ultimately it comes down to device connection dropping. iPad Rehab made a hugely informative video about this if you really want to get into the weeds of what Error 9 ultimately means, and how to find more details when it comes to error code, but it's quite long.

Based on the symptoms you're giving, I'm thinking it could be related to a few things. It sounds like you already checked the dock flex, which was my first thought. My other thought is during disconnection of the display, the little transistors that assist in transmission of battery "gas gauge" data were nudged. This would cause the battery to be unable to send data about its level of charge to other board components and can cause weird power on types of behavior. I would peel up the little foam sticker around the display connector and check along the left edge for any signs that things were disturbed.

Block Image

Definitely add some pictures. It can help us to determine the issue with more certainty.

I will also throw in the Troubleshooting Problems After A Repair wiki just for reminders on things like this. In particular the "retrace your steps" part is tremendously important in my opinion.

Was this answer helpful?

Score 1
Add a comment


A boot loop is generally caused by what's called a kernel panic; i.e., the microprocessor at the heart of the phone runs into an unrecoverable error condition and reboots the phone in an attempt to recover. The 3uTools message you got seems to confirm that, as it looks like the beginning of a kernel panic log.

In order to figure out what's going on with your phone we'll want to take a more in-depth look at your panic logs. @flannelist has written the most authoritative guide to kernel panics that we have available here on iFixit, and it's well worth a look.

iPhone Kernel Panics - iFixit

Use the guide to locate your panic logs and post the first page or so via either cut and paste or screenshots to your question and we'll see if we can figure out what's causing them.

Adding images to an existing question - iFixit Repair Guide

Was this answer helpful?

Score 0


How would I get the panic logs? The phone will not fully boot so I cannot access the settings like that article states.


Right now the phone is stuck in recovery do to an unsuccessful restore.


You mentioned it booted with the replacement battery; can you reinstall that battery and possibly get through the restore?

If it won't boot, you may be able to get through the restore using the new battery and DFU mode.

Also, I understand the logs can be retrieved using 3uTools; unfortunately I'm not conversant enough with the software to be able to tell you how to do that, and I don't know if the phone has to be booted or not in order to get them.


Add a comment

Add your answer

CAB will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 7

Past 30 Days: 23

All Time: 83