Grey Screen Boot, Open Firmware

Hello,

A few years ago my powerbook g4's logic board fried and I kept it in a drawer until a few days ago when I bought a used 1.5Ghz Logic Board and replaced it. Now the computer will boot but I only get a grey screen. I've searched a lot around and the best I could find was this: http://hintsforums.macworld.com/showthre...

that guy has my same problem. It seem though that everything is working fine but I'm not getting anything on the display (except for grey). I can get into Open-Firmware but I'm typing blindly. Does anyone know why this happens and how to fix it?

I have tried

- Reset PRAM, NVRAM

- Won't seem to boot off a CD (with c held down)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Verify that the Airport Extreme card is firmly seated. I've seen cases on the 12" PowerBook where if it's just slightly out of its socket, the machine will go into open firmware, or otherwise act strange.

Beyond that, is it a faint, sort of opaque grey screen, or a solid white screen? The odd-colored grey screen can be an indication that the inverter light is working, but the video signal is not coming across, in which case I'd make sure the video cable is firmly seated on the logic board side. I'd try booting in option mode, i.e. power on with the option key held down, and if you DON'T see the option menu, that generally means you have a video-related issue. You can also try the external monitor as Mayer suggests.

Was this answer helpful?

Score 2
Add a comment
Most Helpful Answer

First try connecting to an external monitor to see if you have video issues.

Was this answer helpful?

Score 3

Comments:

I did. It didn't work...

by

Add a comment

Add your answer

joablen will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 988