Skip to main content

Released in May 2020, the 13" MacBook Pro features quad-core Intel 10th generation Core i5 and i7 processors, and Intel Iris Plus integrated graphics. (Model A2251/EMC3348 with four Thunderbolt 3 ports)

63 Questions View all

MacBook erased, but won't boot after xartutil --erase-all comm

After erasing the MacBook, I also wanted to erase the Touch Bar. However, after the command

xartutil -erase-all

My MacBook does not start anymore. The screen no longer lights up or turns on. Tried all reset commands. How do I get him to work again?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

You'll need access to another TB Mack system to run the Apple Configurator 2 app to try to re-install the system firmware. Here's more on it How to install Apple Configurator 2 for macOS

Basically, putting the system into DFU mode

Try running both Revive and Restore options

Was this answer helpful?

Score 2


Thanks for the answer. When i erased the macbook it worked fine. but after the command xartutil-erase it is complete dead and i also get i not in DFU mode. is ther another solution maybe....?


@maxgeertsen - Your system uses firmware which is stored on the drive which you erased! What made sense in older systems creates issues with the newer models.

The other option is visiting an Apple Store who have a tech that can reload the firmware partition.


Hello, I also deleted the touch bar and I have the same problem as, did anyone manage to restart their macbook after turning it off? Thanks


@rorovd83 - As I explained you need a second system to run the Apple Configurator 2 tool.


Add a comment

Add your answer will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 11

Past 30 Days: 25

All Time: 614