Skip to main content

Released in May 2020, the 13" MacBook Pro features quad-core Intel 10th generation Core i5 and i7 processors, and Intel Iris Plus integrated graphics. (Model A2251/EMC3348 with four Thunderbolt 3 ports)

62 Questions View all

Service battery after update to Monterey


have a a strange situation with a A1989, had to replace the battery on the unit. After battery replacement battery show "service battery" on Monterey 12.4. It only does this on Monterey, Catalina 10.15.6 and Big Sur does not show this message. The battery charges and holds charge with no issue. Tried 3 new batteries and same result.

Steps taken:


Full DFU restore.

archive install

updating from a known working OS.

Can't get rid of the message on Monterey. Also changed the battery to board flex cable with a working one from a separate machine.

Any help would be appreciated.

Update (09/05/2022)

Apologies for the late update, got crazy busy with client units it fell to the wayside, here are all the images available that I have of the issue. booted externally to Catalina were there is no service error and coconut battery screenshot as well as system info. Then the image of Monterey with the service error internal OS.

Block Image

Block Image

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
1 Comment

Let’s get a better view of things, install this gem of an app! CoconutBattery take a snapshot of the apps main window and post it here for us to see Adding images to an existing question


Add a comment

1 Answer

Chosen Solution

Who was the source battery? This appears to be a firmware issue within the batteries micro-controller.

Was this answer helpful?

Score 2

1 Comment:

Is an original battery. Actually this would make sense as we believe that it may be a pulled battery.


Add a comment

Add your answer

Grant will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 10

All Time: 267