Skip to main content

Released in November 2020, the 13" MacBook Pro features Apple's Arm-based M1 SoC with both an 8-core CPU and 8-core GPU. (Model A2338 / EMC 3578 with two Thunderbolt 3 ports)

63 Questions View all

13-inch MacBook Pro 2020 will only charge from selective cable / brick

I have a 13" MacBook Pro 2020


Product #MYD82LL/A

The MacBook will no longer charge from the stock USB cable and charging brick.

Thinking it might be a bad cable. I tried a different USB-C cable (Thunderbolt 3 Cable 40Gbps Supports 100W) and it worked the first time it was connected and would not work after that.

Thinking the power brick might be bad I tried using my Anker PowerPort II 49.5W USB C Charger with my other cable that had just worked but it still would not charge. Before giving up I tried charging it off of my Oculus Quest cable and power brick and it works every time from this. the other power bricks and cords work fine with other equipment but the MacBook will no longer charge from them.

Does anyone know why it is being so selective? I have tried to go back to the stock brick and cord multiple times and my other brick and cord multiple times and it will not charge from them. I'm worried that it's going to stop charging from the Oculus brick and cord at some point.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Did you try the other port? Sometimes one port gets worn and/or the ports logic gets damaged.


Thanks Dan, yes I did try both ports. they both work with the Oculus charger and neither works with the other bricks.


Add a comment

2 Answers

Chosen Solution

At this point I think you'll need to get to an Apple Store or authorized Apple service center as your logic board needs repairs/replacing. This should be covered under warranty!

Make sure you bring the original charger and USB cable.

I'm suspecting the USB chargers dialog is not being understood by your systems power logic. In the days of old the charger was a dumb power source and the computer had a simple MOSFET switching logic (think older Unibody MacBooks) Today we have micro controllers in the chargers which have a dialog to the computer telling it what it is and the computer tells the charger what it needs. This dialog for some reason is not working correctly. I think the logic within the computer is messed up.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

After playing with it more today it looks like the first two usb cords I used went bad. not sure if the laptop is destroying them some how but I bought a new cord today and its working with the stock brick. I have never seen two cords go bad on the same day but I guess it happens. Thanks for the help

Was this answer helpful?

Score 1
Add a comment

Add your answer

Jonathan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 72