replaced left I/O board, still will not charge or even light up.

So last night I sat down and replaced the left I/O board in my MBP 1260 A which had stopped charging after my daughter had spilled a small amount of chocolate milk over the left speaker. After the chocolate milk happened, I noticed it was slowly fading in its ability to charge or even light up on the mag safe power cord. Also of note, I just recently replaced (within the last 4 months) the battery and power cord (85w), so I know they are not the problem. Prior to this I have not had any issues with booting up or the screen. So my question is, what should I do now that I have replaced the I/O board? Do I need to replace the I/O board cable as well or should I just fork out the cash to get diagnostics? Are there any other wires cables that I am missing? I am not that computer savy so I am stumped at this point and don't want to make matters worse.

C2D 2.2GHZ

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Just to make sure I understand, before you replaced the left I/O, was the computer basically working, but just not charging the battery, or was it dead? If it was dead, were you getting a light on the AC? Now that it's changed, do you get no light or a dim light? Have to gone back in and re-seated cables? The cable that goes under the board is tricky to get in there, and if it's not in tightly, the AC may not light up. Also, do you know the new left I/O is good? Lots of people sell them as good when they are actually untested.

by

Sorry to be confusing but the computer has only been out of commission for 2 weeks now. What I meant to say is that since I replaced the battery and the power cord it had worked fine up until the liquid spilling. I did clean the external surface but did not open up to clean internally. Before I replaced the I/O board it was not lighting the ac power cord at all or charging the battery and the battery is now dead. Still no light after I/O board change. I believe it was a good board as I purchased it from a reputable seller. Should I go back in and make sure the I/O cables are in tight? ABCellars if I don't have access to a multimeter, would you recommend just replacing power cable between the boards after cleaning the logic board?

by

Yes, I would test connections first, and it's not uncommon for the primary cable on the underside of the board to become unseated while the whole mess is being pushed together. Try connecting the AC at various stages with the top off, and while you can see that the cables are connected.

by

I would reaffirm rdklinc's suggestions. I will add you can get a cheap analog multimeter to do this job for $20USD or less -new.

by

Okay thanks guys. I will go ahead and try again.

by

Add a comment

1 Answer

Chosen Solution

Dave from what I have read this has been out of commission for 4 months and is not your main computer or one that you can't take your time with.

The magsafe will not put out the 16.5v - 18.5volts it supplies until the SMC and the magsafe are "shaking hands" and the SMC tells the Magsafe it can. Your lack of the LED(s) lighting on the magsafe indicate that the SMC and power adapter don't know the other exists. I would start by checking the magsafe connector for residue or debris. The center contact (the small one) on the magsafe is where it communicates with the SMC.

I see no mention of cleaning up after the liquid damage. That is where I recommend you go even if you find a problem with the magsafe connection - to eliminate future problems.. If you lived through changing the left I/O board you, removing the logic board and properly cleaning it and inspecting it should be within your abilities. Here is a guide for removing the logic board. Here is iFixit's guide to cleaning up after liquid damage. I realize that the milk went in the left speaker. But after it entered who knows where it went and a little bit of liquid goes a long ways.

You are going to need to remove the logic board to test the power cable between the left I/O board and the motherboard. Also, to inspect the socket and the surrounding area where that cable connects to the logic board. By cleaning the motherboard as previously suggested you eliminate any ghost that could be there. To properly troubleshoot this you have to deal with "knowns". You can easily test the power cable between the boards to determine if it is the problem. If you own or have access to a multimeter/multitester (An analog one with the needle, is best for testing internal breaks in wires. The digital ones have slow reaction time.) you can test the integrity of the power cable with a continuity test (resistance test on it's lowest setting) while moving the wires around. Go prong to prong, if the needle sweeps hard at any point the cable more than likely will be the cause. If you find any prongs that have no continuity with the corresponding prong on the other side of the cable you have found at least part of your problem, if not all of it. The fore mentioned should help you determine if the power cable is the problem.

If you have replaced your left I/O board with a good one. Then either that board isn't talking with the logic board or the motherboard has problems. We have previously discussed how to test the power cable between the 2. I would now inspect the cable socket on the logic board for any bent or burnt pins with a jewelers loupe. I would also inspect the area around that socket and the area on the other side of the board directly underneath it for any signs of burning such as discoloration or charring - Inspect both the board and components in those areas. This is a 12 layer board with most of the power running through sub levels.

Obviously if you find problems here they will need dealt with or the logic board will need replaced.

If you take your laptop to any repair shop "worth it's salt", this is the gist of what they would do. Unfortunately. most places specializing in Apple repair are parts pushers and would never pull out a loupe or use a stereo microscope to inspect the socket of the power cable and just call the logic board bad - when the socket may actually be able to be cleaned.

Time is money. If you have the time to figure out if the problem is the power cable, power cable socket or the actual motherboard then follow the steps I have given you. If you don't then throw the $ at someone else doing the troubleshooting and trust they have done it right.

Was this answer helpful?

Score 2

Comments:

+ great advice!

by

Add a comment

Add your answer

Dave will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 6

All Time: 1,947