Skip to main content

The March 2015 update of Apple's 11" MacBook Air features fifth generation Intel Core i5 and i7 processors, resulting in slightly increased performance and battery life.

134 Questions View all

MacBook Air - New battery: suddenly undetected, will not charge

At the weekend I received a new (and apparently genuine) Apple branded battery for my MacBook Air 11 (early 2015). Fitted in quickly and it worked perfectly, showed full expected capacity and would charge and discharge no problem. I ran it through two charge cycles with no unexpected behaviour.

A couple of days later I turn it on in the morning (sitting attached to the MagSafe charger on power) to find no battery can be detected, at all. This includes within MacOS, CoconutBattery, and in Linux OSs I boot into. When I put my old battery in, it is detected and works fine.

I’ve tried (repeatedly) removing and re-seating the new battery, and also have reset the SMC and the PRAM. The weird thing is that (in Linux only) I can remove the power cable once the OS is running, and it will run ok for an extended time on the apparently undetectable battery.

I have a nasty feeling I damaged something in the Mac when I originally fitted the new battery - it’s possible I shorted something. But the fact that (i) the other battery behaves fine and (ii) the new battery worked perfectly for two days argues against this.

What do people think? Is it just the new battery that’s defective? Or have I damaged something on the motherboard?

=== Edited to add screenshots of Coconut

New Battery (not detected)

Block Image

New Battery system info

Block Image

Old Battery (detected)

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
3 Comments

@quirky_cobra - Can you please post a snapshot of CoconutBattery so we can see what it is showing Adding images to an existing question

Also where did you buy the battery?

by

Cheers Dan - this was bought off ebay last week, arrived and fitted on Saturday. I'll get a shot of CoconutBattery - but in outline it shows essentially nothing for the (bad) battery, cannot detect its presence at all.

by

@danj - added screenshots of CoconutBattery for the new (not detected) and old (working) battery. Thanks!

by

Add a comment

1 Answer

Chosen Solution

Well the batteries micro-controller has failed, so the charging logic has no idea what the batteries status is.

Sadly, this is a bad battery. You’ll need to get a replacement from the seller otherwise its $$ for a new one from a better source.

FYI - Anyone can have anything marked on the battery. Apple does not sell parts directly (at least not yet) nor via any one else. You got a knockoff battery, the seller will imply you got a real Apple part which you didn’t.

Thats not to say you got a workable battery as many of the factories which make batteries send quite a few out the back door either as seconds or from a good paying reseller like iFixit who buys very large volumes.

Was this answer helpful?

Score 1

1 Comment:

Righto, thanks Dan, this makes sense. I'm actually relieved in a way as I can get a refund for the battery pretty easily (if I'd damaged the main board that'd be a different story). Thanks again!

by

Add a comment

Add your answer

Jon Ayling will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 60