Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1363 Questions View all

MacBook doesnt power on

Hi, I have a MB A1181 that doesnt power on when press the PWR button, I tried to PWR it with and without the battery with same result (no power on).

Also the battery is not charging, the MagSafe connector shows the charging status (solid amber) on the connector and after 3 or 4 hours got the charged status (green status) but the battery charge status is not blinking and macbook still not powering up.

Any help I´ll appreciate.

P.S. I also tried SMC procedure.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Sounds like your battery is perfectly fine. 4 hour charging time sounds about right, so I would cross battery problems off the list. Have you taken the laptop apart or spilled anything on it? If you have taken it apart recently, it is possible that the battery is not connected correctly, which you could check by following this guide. However, this also sounds like a fried logic board. If you've spilled anything on the device, this is likely the case. Apple has been known to occasionally replace fried logic boards (they did it for me last year), so it would be worth a shot taking it in and seeing what they can do.

I would recommend trying the suggestions above before you replace anything in the device. Respond with updates about how these work for you.

Hope this helps! Good luck!

Was this answer helpful?

Score 1

Comments:

Thank you Jake,

I never taken apart the laptop or spilled something over. As you said maybe the problem is the logic board. Just as a comment. On one of that "charging" cycles the battery showed one led status, I tried to turn it on and it worked but just 5 min because they shutted down.

I´ll keep you updated. Again thank you.

by

Jake,

Thank you for the help. With the tear down process of the laptop I found everything was good on the MB and I figured out that the MagSafe is not wroking properly, some hits to the charger maked it to start charging. It is very curious because the MagSafe led light powered up all the time and thats why I never think it was bad. Now I need to tear down the charger to see what is wrong on it.

by

I'm glad you narrowed down the problem and extremely glad that it wasn't an issue with the logic board! Let us know how the charger teardown goes and feel free to post some pictures if you're interested!

by

Add a comment

Hello ,

i have an macbook unibody a1278 .

Last day i have press the power button it didnt work, i thought the problem is in power cord, than i took my brothers power cord adapter i tested it didnt work again. I took my battery out from my macbook tested again it didnt work again. I asked a friend of mine about this issue he said that it could be a problem in motherboard or magsafe board. Can you please help me with it ?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Homar Lopez will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 6

All Time: 536