Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1490 Questions View all

Apple logo when charging, otherwise dead after drop.

I keep trying the reset/restore method on itunes. My phone will only say "connect to itunes" when plugged into a wall charger (after a couple minutes of charging.) It also constantly displays the apple logo.

When plugged into a computer (laptop or desktop) the apple logo only appears for about 10 seconds then fades away. The "connect to itunes" screen will not appear (even after hours of charging w/ the computer, and multiple attempts of restore mode.)

When I plugged my phone into a macbook, I managed to get itunes to recognize the iphone (in restore mode.) I tried to restore it however it got stuck at "preparing iphone for restore", then gave me an error message (error 1604.)

My phone experienced this problem right after I dropped it.

Is there another way to restore this phone?

should I get another and replace the battery?

or is my phone totally FUBAR?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Not fubar.. Just temporary annoyance. I suspect you've knocked cable no.4 loose or battery connection is awry. Follow directions for battery replacement on the right under photo of phone. Check connector 4 is on (undo and redo it looks like it's on and it isn't), check if it charges.. If no, then go ahead and check 2 screws over battery(1 is under the 'do not remove' sticker..) There is a screw which holds logic board onto battery and in to rear case which can become loose from a drop.( one nearer the vibrate motor) close up again and check charging. Still no charge then tale logicboard off battery and try lifting the gold prongs on battery up a little so they make better contact with logicboard.check battery charge with multimeter.. If it's less than 2.2 you should replace it Close and try again with charger.

Was this answer helpful?

Score 2
Add a comment

Add your answer

glockatized will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 4

Past 30 Days: 7

All Time: 1,342