K45 Elite Won't Pull Water

Hi there,

We’ve had our K45 Elite for a number of years now and it’s always been great, however the last year or so, when it would draw water in from the reservoir, it did sound a bit weird, and prior to the issues I’ll get to, it started to sound a bit weak. But it still worked without fail for generally multiple uses daily.

However, one day, it brewed me about 2 oz of coffee instead of the 10 oz cup I had asked for. I tried to make another cup and it just…didn’t pull more water in (conveniently this was during the first week of work at my new job after having been laid off for 15 months). This is where the issues started and remain today. It basically won’t pull anything in at all. Occasionally I can get it to a point where it will draw water in (usually after a bunch of swearing at it and shaking it up and down while upside down over the sink), and then it’ll work just fine for a number of cycles before it gets to that point where it then doesn’t draw more water in and makes cups that are smaller and smaller, eventually down to about nothing.

Admittedly, I’ve never descaled the thing (nor has the light ever turned on), though I’ve always used filtered water. I’ve tried all the troubleshooting things I’ve seen - manually “pumping” the lines by rapidly moving the tank up and down with and without holding the vent tube up top shut, taking the feed line off the top and making sure the check valve works, making sure the needle holes are clear, etc. When I did get it to work one of the few times, I ran a descaler solution through it - and you can see crap in the lines right near the top of the pump, and a lot of it would come through into a cup, but in the end it always reverts back to refusing to pump when it needs more water.

I’m out of ideas as to where to go next - is this a control board issue, pump issue, something else all together?

Any help would be majorly appreciated, thanks!

Answer this question I have this problem too

Is this a good question?

Score 0


it sounds like you need to try to get it going and run descaler through it more. Or a strong vinegar solution. Try and clean.all that gunk out. It sounds like your pump is either clogging up or failing.


@brandon_k or it's doing both. The lack of it pumping is what throws me - it's almost like it forgets it *needs* to pull more water all of a sudden.

I did think about maybe getting it to a point where it pulls in again and then letting that descaler (or maybe near pure vinegar - I was using a 2:1 water:vinegar solution I typically use for cleaning coffee pots) sit in the pump for a...while.


@mp81 if you do that, let the solution sit for a couple hours, then pump it through and let new solution sit. Do this a few times and see if that doesn't clear out the works



Doing that right now - I took the bottom apart and blew through the intake under the tank for...a while...to maybe help clear it out. Once I plugged it in, it didn't pull any water in on the first "cup", but did on the second. I had emptied the reservoir entirely and put a full 8 oz of descaler in there with as little water as possible to get it above the "Add Water" sensor. I also poured some straight descaler into said inlet before putting the tank on.


After the initial pull or two it stopped pulling anymore, but would brew without going into flashing lights (and "Descale" lit up a few of those times, something it never, ever lit up before prior to all this happening), but basically nothing would come out. Only a little - and only if you shook the machine back and forth rather violently while it was "brewing". About 10 minutes of that and it pulled some more from the tank a couple times and brewed maybe a half-size cup (when I asked for a 10oz), but it was more than before.

I think a fair bit of the super-strong descaler solution is sitting in there now. Will leave it in there for a good while and then see what happens.


Add a comment