Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

677 Questions View all

HD is suddenly not recognized anymore.

Hey,

after a freeze, my MBP doesn't recognize the HD (disk utility), even after a replacement with a new HD. Boot by CD, boot over USB, hardware test, daily use… everything works fine, except for the HD. Can somebody tell me:

- Can this be a problem with the HD cable? The logic board? The EFI?

- How can i check which it is?

- Should i try fixing it myself? I mean, it works fine, i just have to take my HD with me and plug it in USB every time i want to boot my laptop^^

-Should i check if it "rotates" at least? I am not sure about that? Is maybe just something wrong with the power?

I have asked that at other sites too, but as it is a hardware issue, maybe someone here has an answer for me.

Thank you!

Regards

Tobias

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

What was your purchase date and did you take out AppleCate?

by

April 2010, no Apple Care.

by

Add a comment

1 Answer

Chosen Solution

You've already replaced the hard drive and neither your system or disk utilities recognize that either HD exists. You can boot from your hard drive externally. I would replace the hard drive cable. You can find that part here. A guide for replacing the hard drive cable is here. The power and the data travel through different parts of the same cable. If replacing the cable doesn't solve the problem, the issue is on the logic board. Good luck!

Was this answer helpful?

Score 3

Comments:

Thank you very much for your time and answers. I hope this solves my problem.

by

You are very welcome. Good luck!

by

Add a comment

Add your answer

Tobias Hofmann will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 2,002