Skip to main content

Repair guides and disassembly information for the 2017 edition of Razer's 14-inch Blade gaming laptop.

12 Questions View all

Replacement battery is not charging

I recently bought a BETTY4(3ICP4/56/102-2) battery to replace in my Razer Blade 14” (2017). I followed the iFixit guide and managed to have it power on to desktop until it drained (battery arrived almost empty).

The battery isn't charging. I've tried refreshing drivers, checking connections, and battery optimisation instructions. I've reached out to the seller, but any advice or tips would be great please!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Don’t invest any more time in formatting, drivers, or anything else within the O/S until you’ve already ruled out it’s not a software/hardware issue.

There are specific components between your power adapter and the motherboard which make decisions about charging and using your battery. My best guess is that there is a hardware issue in one of these components. If your laptop has a built in hardware diagnostic tool you can try running that, but they have limits on their effectiveness.

Some potential options if you still want to try some things
- Update firmware on laptop
- Try power adapters rated for higher wattage
- If the power-port on the motherboard is removable, you can try replacing that one part and see if that's the culprit.

Was this answer helpful?

Score 0


Thanks for the tip. I think I can confidently rule out it’s not a hardware issue - I checked and the original battery powers, charges, and drains as normal (but quickly) so it seems connectors are okay.

I followed these guides with different connector types:

Razer Blade RZ09-0102 Battery Replacement

Razer Blade 14" (2013) Battery Replacement

Can confirm all relevant firmware are up to date.

The first time the new battery was swapped it turned on and got to the desktop before a ‘locking screen’ window for a millisecond and then turning off (but not shutting down). Now it won’t turn on unless plugged in and I get the ‘0% available (plugged in)’ notification. No charging. Again I’ve tried to ‘battery optimise’ (charging for ‘x’ hours, discharge, etc etc) but it doesn’t even get passed being able to charge.

I’m beginning to think it’s a faulty or incompatible battery, but I’ve checked closely it’s the same type and model.



You can just run Windows 10 Battery Diagnostics on another laptop to decide if it is a faulty battery. Also make sure that the issues are not in the charger or power cord.


Add a comment

Add your answer

Ben will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 23

Past 30 Days: 79

All Time: 624