Skip to main content

Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

951 Questions View all

MacBook does not boot and kernel panics. FIX?

Hi,

I have a 2010 13” 2,4ghz MacBook Pro. The computer does not boot and would kernel panics usually. Here is every OS I tried

Snow Leopard Installer On USB : Goes to Apple Logo and tries to boot but kernel panics halfway.

Yosemite On Internal Drive : Boots halfway crashes and has shows some error log text and has a “NO” sign a few seconds later (occasionally kernel panics)

Yosemite On USB: Same issue as internal drive

Yosemite Install USB: Boots, but “unmounting disk” error when installing

This computer seems to be very tempermental. I gave up and came to the answers community instead. I also tried to reset the PRAM and Option+D and Cmd+R. I don’t know about the logic board. I took the computer apart and I didn’t see any problems. And also the fans run at full speed for some reason, Just a side note. And also I am not using AASP’s. I have already wasted enough time there. Thanks guys!

UPDATE : 5/18/2021

I tried yosemite on an USB and now it will only go 20% in the apple logo progress bar and it will just stay like that forever and doesn’t go any further.

After trying Snow Leopard, the internal drive doesn’t work. I think it’s the SATA cable, but I am not going to fix it until i can get the computer into an operating system. The computer also doesn’t accept : Option+D and Command+R for some reason.

UPDATE: 6/2021

The laptop did boot into every version of macOS using safe mode, but only El Capitan/Lion works using normal mode, but it is EXTREMELY laggy and unusable? Can I still revive this motherboard?

And also the battery doesn’t work, just another side note

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

The panic report often gives clues on what the issue is, I would review it.

Also I would run the on board diagnostics. Restart your system and press the D key to enter.

by

@danj It will just say the normal panic. It will just stay like that forever

by

@danj the computer also would not boot from a working copy of Yosemite for some reason. It would only go to 20% and stay there. I wonder if the MOBO (Motherboard) is still fixable.

by

Add a comment

1 Answer

Chosen Solution

Try running with one SO-DIMM swap them around and try both socket slots

Was this answer helpful?

Score 0

Comments:

thanks, but no it didn't work

by

@rs1020 - At this point Its time to try a fresh drive, you'll need a fixed speed SATA II (3.0 Gb/s) drive which are now getting hard to find or you'll need to get a auto sense drive like the Samsung 870 EVO note the interface line lists 3.0 Gb/s (SATA II) make sure what ever drive you get lists your systems speed, if it doesn't it won't work properly in your system.

by

@danj yeah much faster now! thx very much

by

@rs1020 - Happy to hear the issue was the drive! Don't forget to score and accept the answer - Thanks!

by

Add a comment

Add your answer

ryoseo1020 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 3

All Time: 38