Mid 2006 / model number A1181 / black or white case / 1.83 or 2.0 GHz Intel Core Duo processor.

509 Questions View all

Disassembled MacBook to install part, now won't turn on.

Without going too in depth to the original problem, I had the backlight of my Macbook die a few weeks ago, and I opened it up to try and see what the problem was. I knew where I was looking after some Googling, so I didn't prod around too much. The inverter cable seemed dodgy and the screen would flicker when moving it, so I established that was the problem.

I ordered a new inverter cable, which has just arrived. I installed it and with fingers crossed, pressed the power button - nothing. No chime, no noise. It doesn't power on. It was powering on fine when we had it apart and testing for the backlight problem and we haven't touched it since then.

I can't see any visible signs of damage, the board isn't fried and there are no cables melted or damaged.

For no reason in particular, when I tried it earlier, it powered on for a minute or so and then went off, but hasn't come on again.

The Macbook is a late 2006 Core Duo model (I know, it's old, but I can't afford a new one and really need to save this)

Does anyone have any advice?

Much appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

I've just tried a friend's charger to eliminate that, and the light isn't coming on at all from it. Could it maybe be the magsafe connector?

by

Add a comment

1 Answer

Chosen Solution

PRAM, SMC resets ?

Since you worked on the inverter cable near the magsafe board you should double check the magsafe cable connection to the logic board.

Also, completely remove the top case, unplug the top case cable connector, plug the ac adaptor and try to boot the machine bridging the two power pads located between the fan and the optical drive connector on the logic board. If the machine powers up then the top case is in trouble. If it does not,:

- check ac adapter

- replace magsafe board

- replace logic board

Was this answer helpful?

Score 3

Comments:

Can't do PRAM as it won't power on and I've tried SMC but I'm not even sure if the power button is working.

Just checked the magsafe connection and it seems okay.

The top case is already removed and I tried the power pads and that doesn't seem to have worked.

by

Were you grounded when you worked in the machine ? Static electricity can ruin electronic components.

Next step would be to replace the magsafe board. Good luck !!

by

Add a comment

Add your answer

Kieran will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 5

All Time: 1,037