Skip to main content

2.2 GHz (Turbo Boost up to 3.4 GHz) or 2.5 GHz (Turbo Boost up to 3.7 GHz) quad-core Intel Core i7 processor with 6MB shared L3 cache.

398 Questions View all

Need advise further debugging "Black screen no chime" issue

Hey all,

I am aware this question has been asked frequently and I went through all suggested answers I have found here and on other portals. I will lay out the situation and hope someone could share advise on what else to try or help me further identifying the root cause or suggestions on best dealing with this.

As stated, this is about a Macbook Pro 15” Retina, mid 2014.

It was still on Mojave and I went to install a suggested security update.

When the loading bar of the update said “2 Minutes left” I went to refill my coffee. Upon return the computer was shut down. I waited for a few minutes to make sure its not currently restarting. Nothing happened.

From thereon out, when I try to turn it on, the screens remain black, there is no chime and the fans (very silently) start spinning for approximately 15 seconds and then the device switches off and after 5 seconds automatically back on. This cycle never ends, until I press and hold the power button for about 10 seconds to turn off entirely.

Here is what I have tried so far:

- SMC reset (power adaptor blinking once when successfully performed but no results)

- PRAM reset (hard to judge because without chime and the short lifespan of the boot loop, it seems not possible)

- Key combinations on startup (alt, D, recovery etc.) no results

- The USB ports seems to be functional as a plugged in USB stick or external drive will light up for a few seconds during the “on” phases of the power cycle loop

- Connecting external display: Not connected message appears and no signal coming through - no results

- I removed the SSD and tried it in a different Macbook. The SSD is fine, all my data is still there and boots fine in my other Macbook (15” Retina, 2015 model).

I conclude it is not SSD related.

I inspected the Macbook from the inside and cleaned the dust. There was some, but not much. There are no visible marks of liquid damage, overheating or anything that would look suspicious to plain eyes (I don’t have a microscope or alike).

Other desperate moves performed based on suggestions found online:

- Disconnected the I/O board - no changes

- Disconnected battery and charger, held power button for 10 sec., replugged and tuned on: This lead to the fans continuously spinning at low speed, without power cycling after 15 sec. but otherwise no change. No chime. Black screen.

- Testing if Caps lock led works: It does not

I read elsewhere that “it is not passing POST” - without knowing what this means really.

The battery had been replaced by Apple in September 2019 as the old one started bloating and is rather new. After this battery replacement, there has been a similar thing happening upon installing an update, but back then SMC and PRAM reset at least got me back into recovery mode to apply an old backup that made everything work again. I took the device to the Apple store again and was sold a “heat sink replacement” for about 100$ (Euro). Never understood what a passive component should have to do with it, but it was usable again without any issues until now.

I am puzzled why this is happening coincidentally with a software update… again, sort of. But conspiracy theories aside, I assume the issue to be the logic board, CPU or graphics unit.

These are my questions:

Any ideas on what else to try to further narrow down the root cause?

I don’t trust this device anymore and am uncertain whether any repair would make sure it becomes fixed for real now… what is the likelihood of something being broken that upon replacing components would break the new ones as well?

Assuming it is one of the rather expensive components to replace like the board or i7 - do you think the market value of the device would justify the investment to get it repaired?

Would you sell it broken on eBay or first repair and sell when working?

Thank you for your time! I would much appreciate your input on the matter. I was planning to hold out for M1X or M2 to reach the market and more software being natively supported before making the switch, but I knew my Macbook was on its last paces. So no big surprise and just wondering how to best play my cards from here on out.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer


It would seem like your macbook pro might have overheated. I would start by replacing the thermal paste. That way you can make sure the heatsink is attached properly.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Barry Potter will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 10