No Wifi with closed lid

MacBook Pro 15" 2.16GHz Core Duo Model A1150

I mostly use my MBP in "closed-lid mode" and connected to an external monitor. The problem is the 802.11 signals cuts out when the lid is fully shut. Not completely, but it's either sporadic or "trickles", because a web page will take about 5 mins to load. Therefore, I have to open the lid a few inches to be able to use wifi. It sucks. Another possibly related problem is that the hinge is loose.

Bluetooth signal quality always sucked, but I've learned to live with it. I like my Mac, but shame on Apple for the expensive power supplies with connectors that break so easily.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Replace your antennae cable: MacBook Pro 15" (Model A1150) Airport Antenna Cables

Was this answer helpful?

Score 5

Comments:

Thanks Mayer. Hopefully I can find one up here in Canada. Any idea how they fail? I've got the antenna module in my hand but I don't see any damage at all. The corner contact on the Airport board which appears to connect the shield to the MBP chassis looks quite oxidized though.

by Joe

It worked! I ordered an antenna assembly from powerbookmedic.com for $0.95 + $2.86 S+H, installed it, and now my wifi works with the lid closed. Thank you so much, mayer. . . Now if only my bluetooth keyboard and mouse would work better together with the wifi :(

by Joe

Dear Joe, That's great that you go tit running especially at that price. Now write another question and tell us about your keyboard and mouse ;-)

by mayer

I celebrated too soon. The problem is back today.

by Joe

Add a comment

Add your answer

Joe will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 966