Skip to main content

In June 2017 Apple updated its 13" MacBook Air with a newer Broadwell Intel Core i5 processor, resulting in slightly increased performance and battery life.

307 Questions View all

Why do I have "No input or output devices found" in MacBook 2017 sound

All of a sudden, I have no sound on my MacBook Air. If I hit F10, F11 or F12, I get the circle-slash “forbidden” sign.

After searching for solutions, I think I may have reached the end of the road. Is there anything more I can do?

  • 
I tried pushing in and pulling out an earphone jack several times. There is no red light on.
  • 
I put a tiny screwdriver in the hole and moved it around, no response.
  • 
I reset the PRAM.
  • I reset the SMC.
  • I ran the diagnostic test — no errors.
  • I restarted in recovery mode and ran first aid. I reinstalled Catalina OS. I never get a chime.
  • I upgraded from Catalina to Big Sur.
  • I deleted the BezelServices preference file.
  • I deleted ‘coreaudiod’ from Activity Monitor.

The only things I have left to do is

(1) wipe the machine entirely and restore.

And (2) follow this guidance for replacing the audio cables on a different model MacBook from mine.

I have a MacBook Air (13-inch, 2017). I had the logic board repaired after a water spill about six months ago from a third party vendor. He also replaced the I/O Board Flex Cable and Trackpad/Keyboard IPD Flex Cable.


I’d rather not buy a new computer. I know from reading Apple Support Communities that bringing it to the Apple Store, they’ll just want to repair the logic board, and that’s more than the computer is worth.

Can I just buy a bluetooth headset or USB audio adapter? Will that give me audio input and output?

Sometimes in "output" in the "Sound" System Preferences pane I get the message:

Select a device for sound output: Name: Apple TV // Type: Airplay:

I don't have an Apple TV, but maybe the guy in the next apartment does. Still, when I try to turn up audio, I still get the circle-slash sign.

Coincidentally, my VLC has been having problems. It plays, but it freezes if I advance the video. It never used to do this before.

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

try headphones wired and Bluetooth. If they don’t work it could be an ic chip then needs to be replaced on the motherboard. If the headphones do work it might be a fuse for the speakers. I would bring it to a repair shop and get a free estimate and there they can also tell you what’s wrong.

Was this answer helpful?

Score 0

Comments:

Thanks -- I tried the wired headphones, no luck. I'll have to buy some bluetooth headphones.

by

Add a comment

Add your answer

AndrewC will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 16