Skip to main content

Repair guides and disassembly information for the MacBook Pro 16'' released in November of 2019. Model A2141, EMC 3347.

96 Questions View all

External USB Camera keeps turning on and off (see video)

I have a Sony camera connected via the elgato camlink stick. Everything worked fine, until I plugged in a multi-usb adapter. Then this strange behaviour you can see in the video occured, forever :(

Here are some logs

Block Image

Block Image

  • Turned off and on
  • Tried another Macbook (same behaviour there, very strange)
  • I reset the SMC and PRam.

Update (03/24/2021)

Hi guys, thanks for your support!

I do not know why, but it works.

I changed the adapter and everything works fine. That is weird, because everything worked fine with the adapter that I exchanged. Thanks for your thoughts @logixal, inspired me to adjust a cable.

I am not sure if this will help anyone out there, as my setup is quite specific.

But what I can tell (if someone stumbles upon these error messages) that this must be some software related issue. I am not sure, if the third party usb hardware that I have plugged in updated my usb drivers. Being uncertain, my next step would have been @danj s advice, speak to elgato / apple and sending them some of my logs (spotlight -> console).

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

What happens when you directly connect the Elgato Camlink stick to your system? Or another system which has a USB-A port.

by

@danj Hi Dan, everything works fine on my Windows (direct USB-A connection). But I am pretty sure it is not an issue with the adapter (worked fine before). I think it is a problem with my Macbook. I uploaded a screenshot with some logs (console).

by

Add a comment

2 Answers

Chosen Solution

If its a high def camera you might need its own hub to operate. the cam link draws power from the USB correct? There’s no other power source for it?

I had a problem with having my HD camera plugged in and my Elgato on the same hub. It would cycle my camera on and off. You may need to get a USB Power booster to run both on the same USB outlet.

Was this answer helpful?

Score 1
Add a comment

@Alex Friedl - The log entries imply a OS level issue not hardware.

You'll likely need to speak with Elgato on their Camlink stick drivers and you may need to also talk directly with Apple.

I would also try using a USB-C to USB-A converter or a real Apple USB-A dongle to see if the hub you are using is a factor.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Alex Friedl will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 14

All Time: 117