Skip to main content

Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

427 Questions View all

New SSD restored from TM not detected internally — but is externally

First post here — hope someone can help.

I restored onto a 2TB Crucial SSD (CT2000MX500SSD1) from Time Machine and attempted to replace the existing 500 GB HDD with it, but on booting it up I get an alternating question mark folder icon with the Apple logo and a cross icon. I can successfully boot up the iMac with this new SSD via an external caddy (through the USB port) — but not internally.

I double-checked the internal connections to the SSD with the SATA data and SATA power cables but they seem nicely connected and I’m still getting the same issue. I then put the original 500GB HDD back to check I hadn’t damaged the cables / sockets but it booted up fine. I then replaced it back with the new SSD and still got the non-detection issue.

On a side note, not sure if this is related, but might be worth mentioning. When I tried to boot up externally with the original HDD via the caddy, the iMac wouldn’t detect it, but does detect the old HDD internally — and as mentioned, the caddy works fine booting up the iMac with the SSD.

Thanks for any help.

Update (03/20/2021)

When I boot up with the Option key, it shows me the disk (SSD) and when I select it I get the flashing question mark folder > Apple icon > circle with line through icon — all on a rotation

These are the steps I took:

1. I removed the original 500GB Seagate HDD from my iMac and attempted to fit the SSD directly into the space (straight from the packaging without doing any preparative work) utilizing a new SATA cable and 2.5" to 3.5" mounting kit

2. I then rebooted and hoped to see the new SSD to perform a restore (tried holding down the Option key (for the startup manager) and again with Command+R (for recovery)) but couldn't see it

3. I opened the iMac again and double-checked the internal connections to the SSD with the SATA thermal sensor, data and power cables but they were nicely connected and I rebooted but still got the same issue

4. I took the SSD out of the iMac and used my 2018 MacBook Pro to erase and format it with the Mac OS Extended (Journaled) option

5. I then tried refitting it again in the iMac and rebooting. Still no joy

6. I tried again without going via the thermal sensor SATA cable but instead going directly with the iMac SATA cables — still no use.

7. I then decided to use an external caddy for the SSD to connect to the iMac via USB where I could successfully initiate an internet recovery to install MacOS and then do a TimeMachine restore

8. Whilst it was connected externally via the caddy it booted up okay and I could use the iMac as normal — but obviously I want to install it internally

9. I then opened up the iMac again and tried to install the SSD, rebooted and it failed again

10. I then put the original 500GB HDD back in to check I hadn’t accidentally damaged the cables / sockets but it booted up fine. I then swapped it back with the new SSD but again got the non-detection issue (flashing question mark folder > Apple icon > circle with line through icon — on a rotation)

Answer this question I have this problem too

Is this a good question?

Score 0

1 Comment:

Are you sure you formatted the SSD correctly? There are a few things you need to be careful here.

1 - Using GUID partition table

2 - Using the correct file system the system is expecting HFS+ (Sierra or older) or APFS High Sierra and higher)

3 - If the systems firmware got the needed update to run APFS drives.

So I'm suspecting you used a different system running APFS to setup your SSD drive and your Mac's firmware was not updated so the SSD work boot up as it doesn't understand how to.


Add a comment

1 Answer

Your system is messed up on which drive to boot from! You’ll need to go into your systems preferences to reset it.

But you first need to boot up with your SSD mounted internally. To do that you need to use the startup key Option (⌥) key to enable the Startup Manager so you can select the SSD. Once your system is booted up go into the preference setting > Startup Disk to set it permanently.

Reference: Mac startup key combinations

Was this answer helpful?

Score 0


Thanks — maybe I didn't format it correctly then.

I used the Mac OS Extended (Journaled) format (through Disk Utility on my MacBook Pro 2018 — Big Sur). I can still boot up with it with this format and run the iMac, but only via an external USB caddy.

It's a mid-2011 21.5" iMac running on High Sierra, so based on your advice it needs to be formatted with APFS. Do you mean the Scheme should be 'GUID Partition Map'?

The APFS formatting options are — does it matter which one?:


- APFS (Encrypted)

- APFS (Case-sensitive)

- APFS (Case-sensitive, Encrypted)

The Boot ROM Version is — I think it's the latest version? I think I need to go back to Lion to install any firmware updates...



I would just run the OS installer again from the iMac to make sure the firmware has the correct version and is setup for High Sierra if thats what you are going to run on it (the highest Apple supports on this system)


Add a comment

Add your answer

Pri UK will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 55