Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1493 Questions View all

Battery replaced, phone has power but battery will not recharge.

Hi,

My old iphone 3G all of a sudden packed up charging, the battery died and I got no response from it at all. I got hold of a new battery & flex cable, as well as a new power button (this was a another problem that had developed) and opened it up and switched them all. Put it all back together again and tried charging it just now and I can see that when it's plugged in to a power source it is working ok. It seems that the phone is running off the battery's power supply. However, when I try to charge it again the battery doesnt recharge. The phone senses the power and does everything that it should do but just fails to charge up again. I have since tried another battery and it has the same problem. When the phone is not connected to a power supply it is still powered up ok, that is until the battery runs out, then of course it won't charge and won't turn on or anything. It just displays the low battery sign that all iphones do when you plug them in with no battery but as I said, it doesnt charge. I don't think it is connector 4 within the handset as this seems pretty well connected whenever I shut up the phone.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Thanks for the tips everyone. I complained to the guy I got the battery from and he sent me another. I replaced it with this one and it worked fine. :)

by

Thank you for accepting my answer and I am glad it worked out for you. All the best to you and your phone;-)

by

Add a comment

3 Answers

Chosen Solution

Since it all seem to function the way it should when you have auxiliary power, I would think that it is your battery. It may be A. discharged to the point that it will not take a charge or B. one of the ones that gave everyone a hard time a few month ago. There is apparently a bad batch of batteries. I would try another battery.

Was this answer helpful?

Score 1
Add a comment
Most Helpful Answer

Hello,

Possible solutions:

1) Please look at the battery installed and tell us the model number. There is 3G and 3GS batteries, it sounds like you may have put a 3gs battery in the phone.

The model number of the old and new battery should be very similar (sometimes the last number will be one digit off).

2) Possible faulty dock. Do you have a replacement you can try? Swap out the bottom dock for a new one.

3) It sounds like all your cables are plugged in correctly. If the above two solutions do not work, it's going to be your main board. Not much you can do for this one.

Hope this helps,

Xico Solutions

Was this answer helpful?

Score 1
Add a comment

I have seen this only in jail broken phones. Is that the case with your phone? You may need to do it over or use a different software.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Che Thomas will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 708