Pixel 3 won't charge. Tried everything.

This a a refurbished unit from Google. My first device died after the battery expanded and Google VERY reluctantly gave me this refurbished unit as a replacement. That was about 5 months ago.

Now it will not charge while powered on. It will charge if powered off. Wireless charging works but I do not own a wireless charger. It will charge when connected to PC but only after going to USB Preferences and changing it to This Device.

I had the USB power adapter changed at a local repair shop. Same behavior. They thought they had fixed it but all we figured out is it will charge while on if using a Mac USB Charger (which I believe has a high output?).

I have tried other cables etc. My power brick is the original one from Google. That brick and cabel charges other Android phone just fine so it’s not that.

The “Android System - Charging connected device via UBS” notification is always on. Thought there was a short and that’s why I had the USB Power Adapter changed.

I also did several factory resets. No dice. In fact that last one lost a bunch of data that didn’t come back this time.

I feel I’ve tried everything. Google told me to take a hike. I’m still paying this phone off for another year. Overall the worst device I’ve ever owned.

Any other ideas would be much appreciated. Thanks in advance!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment