Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

691 Questions View all

2010 MacBook Pro 13" Sound lost completely?

All of the sudden my sound has stopped to work, when I click on the sound icon, the volume is all the way down and is locked. The volume buttons when pressed, do the same thing, the volume icon has a circle and a dash inside it. When I plug in head phones, the same thing no sound whatsoever.

Under system preferences/sound/output it says that there are no output devices found, and the Input devices same thing no output devices found, and the output volume at the bottom of sound preferences is shown as mute, and mute cannot be unchecked.

The only way that I can make my sound work is when I use my bluetooth headset, the the device is recognized and I can here any sound through there, otherwise all sound in my computer is dead.

Please help me, I do not know how to fix this.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

The first thing you want to do is make sure it is not a software issue. re-install the OS on a spare HDD and see if the sound works there. You can also pull the HDD from another apple and boot from it this will work just as well. It is also possible that there is something wrong with the logic board. I have seen the sound processing chip as well as the amplifier chip go bad on these boards as well as a number of other components. Are you sure you did not spill anything on the laptop?

Was this answer helpful?

Score 1

Comments:

Max, thank you so much for responding my question I will try that and will later post here my results, Thanks

by

Add a comment

Add your answer

Ernesto will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 4

Past 30 Days: 30

All Time: 2,045