Skip to main content

Fix Your Stuff

Right to Repair

Store

Released September 16, 2016. Model 1660, 1778 Available as GSM or CDMA / 32, 128 or 256 GB / Rose gold, gold, silver, black, and jet black.

1909 Questions View all

Taptic engine not working after water got in

My iphone 7 taptic engine stopped working after a few hours after my phone got wet. The LCI is red, I powered off the phone and opened the SIM tray and let it dry overnight, but the taptic engine still doesn’t work.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Only if is 100% clean water you can let it dry, anything else will left residual materials that will start making contact between small components inside of your phone. Take it apart and clean it, if the tactic engine still not working, replace it, and if it still not working check the motherboard.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Boeing will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 8