Skip to main content

Fix Your Stuff

Right to Repair

Store

Released in 2013, the Asus X450 is a 14-inch laptop with a 1366x768 pixel display.

4 Questions View all

My laptop can't turn on despite being plugged in

As an addition to the title, the power light and internet light are flickering faintly, no battery light however. Just before this it boots just fine but I did a combination of power button and F12 (I mistook for BIOS key) and it suddenly shut down with the current state. I did try hard reset but nothing happens. So did I destroyed my laptop? Btw on the back it says “X452LAV". In addition I also replaced DVD drive with a new HDD. In the current HDD I have a faulty Win hence the mistake I made. If needed, I can shoot a short video with the laptop.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi @whyididthis ,

Not sure what you mean by a hard reset, but try a power refresh and see if that fixes the startup problem at least far enough to get into BIOS.

Here’s the procedure:

Disconnect the charger (if connected)

Remove the main battery from the laptop.

Remove the RTC (Real Time Clock) battery from the motherboard and leave out for about 5 minutes. Remember the orientation of the battery for when you have to reinsert it. Usually it is +ve on top (marked on battery). Here’s a video showing the disassembly of the laptop. The RTC battery is located on the underside of the motherboard so it will have to be removed to access it. Here’s an image taken from the video that shows where it is. Also when the battery is out measure the voltage of the battery. If it is <2.6V DC, replace it. The battery type is marked on the battery itself (usually a CR2032 or CR2026 available most everywhere). This battery (non rechargeable, lasts ~5years) maintains the BIOS settings when the laptop is off and when it is low the settings may become corrupted preventing a normal start.

Block Image

(click on image to enlarge for better viewing)

Reinsert the RTC battery (remember the orientation)

Reassemble the laptop. Perhaps leave the HDD (C: drive) out at this stage so that it doesn’t interfere with the startup

Reinsert the main battery.

Reconnect and switch on the charger and try to start the laptop and get into BIOS (press F2 on startup when Asus logo on screen)

If it starts there may be a message saying that the date and time are incorrect. This is normal as the BIOS has been reset. Once the date and time have been corrected the message won’t show the next time the laptop is started.

Was this answer helpful?

Score 1

Comments:

Ok I tried it and well it didn't work. The same thing happens. The lightbulb icon and the internet icon's light keep flashing while charging and the screen is still not working.

by

@whyididthis

Do you mean the WiFi indicator LED when you say internet?

A blinking power light usually means that the laptop is in sleep mode.

What happens if you turn on the laptop and get the blinking lights and then press and hold the power button do the lights eventually turn off or is this how you have to turn it off anyway when it doesn't start?

What happens if you press Fn + F7 after the laptop is on and the lights are blinking is there anything on the screen?

by

The laptop is not even on to have the lights flickering, I just plug it in

by

Fn+F7 does not work

by

@whyididthis

You could check that the charge port is OK and that its connections to the motherboard aren't shorting out because the lights shouldn't be on if the charger is not switched on.

Other the that, without the schematics it will be difficult to find the problem.

try searching online using the motherboard's "board number" that is printed on the motherboard itself. (can't see it too well in the video) i.e Search for "(insert board number)schematics". Sometimes schematics are available online.

by

Show 1 more comment

Add a comment

Add your answer

RandomTechDestroyer will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 3

Past 30 Days: 4

All Time: 62