Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1438 Questions View all

Why can't I Open PPC apps?

I can no longer open AOL 10.3.7, Appleworks 6, or HP PSC 1310 software.

Everything was functioning in the morning and then I went to the library and when I awakened my MacBook. These would no longer function.

Also the Text in the tool bar has been replaced with alphanumeric designations:

Answered! View the answer I have this problem too

Is this a good question?

Score 0


I have not upgraded to Lion as yet. I started to after this problem popped up, but stopped because I was reading the comments as it was downloading and found that Lion was even worse.

To Mayer, I've been relieved to find that it is not a hardware problem. I went to System Preferences, then to "ACCOUNTS" and logged on as a guest. Lo and Behold, AOL and my HP PSC all-in-one 1310 software worked. When I switched back to the Main account the problem remained. I have no idea what has happened to the Main account. I've been thinking that the finder may have become corrupted (the alphanumeric substitutions in the tool and menubars).

I can't find anyway to replace the Finder. I've run utilites and reinstalled Snow Leopard from the disc, upgraded the software to 10.6.8 after the reinstall and in neither case was the problem removed.

Good luck let us know if you have better luck.


I'm having the exact same issue. Running 10.6.8 on a MacBook Pro. Worked fine in the morning, now all my PPC apps crash upon launching. Anyone know what's going on?


Did you install an app or font before this happened? Corrupt fonts as well as plist corruption can cause wonky app behavior. Also check if is Rosette is enabled on those apps. Here's how you can force a Universal application to open using Rosetta:

1. Click the application's icon in the Finder, such as Safari's icon.

2. From the Finder File menu, choose Get Info (or press Command-I).

3. Select the checkbox named "Open using Rosetta."

4. Close the Get Info window.

Now, when you double-click the application, it will open with Rosetta, and any non-Universal plug-ins should work.


Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

2 Answers

Chosen Solution

Sounds like you've upgraded your system to 10.7, which won't run PowerPC programs.

Mac OS X applications that can run natively on both Intel processor- and PowerPC processor-based Macs are called Universal applications. Even if you don't have a Universal version of an application, you can still use it on an Intel processor-based Mac by means of Rosetta, which comes with every Intel-based Mac. Rosetta works behind the scenes to translate an existing, native, non-Universal application (one that was designed to run natively a PowerPC-based Mac, not a Classic application) so that it can run on an Intel-based Mac—all you have to do is double-click the application!

Sometimes, you might have a Universal version of a graphics or Internet application on your Intel processor-based Mac that you want to run via Rosetta instead of running natively. Because some Universal applications may continue to rely on existing plug-ins, you may sometimes need to force a Universal application to run in Rosetta to accommodate the plug-in. Check with your plug-in manufacturer(s) to see if Universal versions are available, too.

Was this answer helpful?

Score 4
Add a comment

I finally got this working again by reinstalling the OS via the install CDs that came with my laptop. Be sure to go in to Customize to make sure Rosetta is selected. Since my disks were 10.6.3, I then had to apply the patches to bring it to 10.6.8.

This process didn't work the first time I tried it, but stuck the second time. Thankfully I decided to try it one more time before resorting to reformatting and restoring from a backup.

Note - I could not open any PPC apps in any of the user accounts on my system so I knew it was a systemwide issue. I've seen other reports that problems were only seen on certain user accounts. I also had not installed or changed any configurations before this happened. I assume some how the Rosetta files got munged and needed to be restored.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Shadow0109 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 477