Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1370 Questions View all

No Boot, Black Screen

I have a MacBook Core 2 Duo 2.0 13 White A1181 2200, which I believe is late 2007. It stopped booting, now no boot, no beeps, black screen, can't hear drives, nothing. I've tried troubleshooting per ifixit, as follows:

Memory - removed memory, tried one stick at a time, swapped sticks between slots, no change.

Power adapter - LED on MagSafe power connector is green. With a machine this old, I think the battery is probably dead, should it show orange, as in trying to charge the battery?

DC-in board - see above, other than that I don't know how to diagnose this.

Logic Board - see above, other than that I don't know how to diagnose this.

Assuming per the above that it's not the memory, I'm in rural Mexico and don't have access to a known good Power adapter or DC-in board to test with, let alone a good logic board. It's a little expensive to just start buying the parts without knowing which is bad, and hey, what if it's a bad processor or something else. Anyone got ideas as to how to diagnose further?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Hi guszernial and welcome to iFixit Answers.

Assuming that no liquid was spilled on your macbook then your unit seems to have a power issue. The procedure steps to troubleshoot this problem would be:

1- do a SMC reset.

http://support.apple.com/kb/HT3964

2- check your AC adapter functionality on another mac and your battery status by pushing the button on the battery (doest it still has a charge, any of the four green dots lighten ?)

3- If the battery has charge and the AC adapter is working then the problem could be:

- faulty or disconnected Magsafe board

- faulty or disconnected top case cable or faulty power switch.

- faulty logic board

The cheapest part to replace first is the magsafe board. You can buy a replacement one here on iFixit or LaptopAid on ebay. I would begin by removing the macbook top case and make sure the top case ribbon cable is well connected to the logic board then try to hit the power button with the top case still unscrewed (with ac adapter connected). If still no power, check the magsafe connector to the logic board, try to reseat it and do another restart. Again no power ? Remove completely the top case and try to start the machine directly from the logic board by bridging the two power pads located near the optical drive connector on the logic board. Make sure the ac adapter is connected to the unit and the battery attached if there's still a charge in it. No power again, replace the magsafe board or the logic board.

Block Image

Was this answer helpful?

Score 4

Comments:

First of all, I'd like to thank lemerise for a very well written diagnostic procedure.

I followed it, and here's what transpired:

I had already tried resetting the System Management Controller (SMC), which didn't help.

I "remove(d) completely the top case (to) try to start the machine directly from the logic board

by bridging the two power pads located near the optical drive connector on the logic board".

No boot, no sounds, black screen, no nothing. Even after charging the battery, see below.

I then disconnected, removed and reconnected the Magsafe board. Interestingly, while the Magsafe adapter

had previously shown only a green LED, thereafter the LED was orange for a while, then green, presumeably

charging the battery. When I then pressed the battery button it showed five green LEDs, presumeably

indicating battery now charged.

Since the Magsfe adapter/board seem to support charging the battery, should I assume that the problem

must be a bad logic board??

by

Well, the magsafe board does not charge the battery but it gives power to the logic board and to the battery charging board to charge the battery. For sure, before buying a logic board i'd try another magsafe board just to be sure but I'd suspect the logic board in this case. I'm working on a 1181 2.4ghz with the same problem and found out that the logic board is the culprit. Good luck with your repair...

by

Add a comment

Add your answer

guszernial will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 10

All Time: 1,260