Skip to main content

Lenovo B50-80: Affordable & Configurable 15.6" Notebook. Combining power and performance with rich multimedia features, the Lenovo B50-80 laptop can raise productivity levels - without breaking the bank. Easily configurable,

12 Questions View all

Power + Charging LED come on when power button pressed, but no boot

Let me start off by saying this is actually a Lenovo B50-10, not 80. iFixit did not have this model listed on their device list.

I can get the battery to charge, and I can tell it has over 20% charge as the LED indicator went from orange to white. When ''''I try to power the machine on using the power button I get a white LED from the power indicator and an orange LED from the battery indicator, but no boot. I can feel the CPU getting warmer each time I attempt this.

I have unplugged CMOS and the battery and held down the power button for 20 seconds but this did not fix it. I have tried the bare minimum number of components plugged in (just battery and LCD) and still no boot. I have reseated the RAM. What could be causing this? Is the power button not communicating that it wants to boot and I just get LED indicators instead?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Have you tried taking out the battery and attempting to power up with just the charger plugged in?

The battery could be defective

by

Yeah, it does the same thing, only without the battery LED lighting up.

by

@ptrma

So I take it you can't even get into the BIOS?

Did anything suspicious happen before this problem appeared?

Any clues?

Are any of the lights blinking. Look at User Manual for codes for lights page 9.

Have you checked out the Service manual?

https://pcsupport.lenovo.com/cr/en/produ...

Is the charger working proper? Correct voltage?

by

Add a comment

2 Answers

Most Helpful Answer

Same problem here.

I have used a USB tester and I see that when the white led turns on there is voltage (5V), but when it turns off there is no voltage.

I have removed the Ram and the white led remains stable and there are no electrical drops.

I have tried to replace the ram module, but nothing is displayed on the screen.

Was this answer helpful?

Score 1
Add a comment

Please make sure that you do not have any external devices connected (mouse, keyboard, usb devices, etc.) as these can cause issues.

If there is no noise from the computer case or fans, the lights on the computer do not illuminate, and the screen is not receiving a video signal, your computer might not be receiving power. As you have already tried removing the battery, another option for you may be to follow the power issues troubleshooting steps.

If it's no problem with the poswe supply, it could be a problem with an internal component.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Panda Tech RMA will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 18

All Time: 527