Skip to main content

Fix Your Stuff

Right to Repair

Store

Released September 16, 2016. Model 1660, 1778 Available as GSM or CDMA / 32, 128 or 256 GB / Rose gold, gold, silver, black, and jet black.

1833 Questions View all

iPhone 7 not detected in recovery/dfu mode?

Hello, I recently bought a 25$ iPhone 7 to restore with a good 128gb motherboard, however I decided that I wanted to do a logic board swap with another iPhone 7 mobo I had bought because it had the original home button with it. After installing the new logic board, I was surprised to see it stuck on the Apple logo and boot-looping, as well as not being detected in recovery mode. So I took that board out and put the old one in just in case I was losing it, and after re-installing it, the old board, too, started doing the same exact thing: Boot looping, and stuck on the apple logo, unable to restore because recovery and DFU modes don’t work since none of my 3 computers can detect the phone when it entered that mode. I have tried a new dock, new cables, multiple computers to no avail. All the screws are in the board in their correct holes so I know i’m not missing any grounding, and I have tried unplugging everything except the bare essentials to see if it was a failing component, but no. I actually tried to re-install the new board as well, and it started working for a while before I unplugged the cable, and plugged it back in, then the phone shut off and started bootlooping. Can anyone help me figure out what on earth is going on here? I feel like I’m losing my mind! Thanks for helping, Ben

Edit: I have replaced the battery with a quality known-working high-capacity aftermarket battery, and have tested the board with the original working Apple battery.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

You haven’t mentioned a battery replacement. A faulty battery can cause these symptoms.

by

@imicrosoldering Oh sorry, I actually replaced the battery with a quality aftermarket battery that I know works, and swapping it out with the original battery made no difference.

by

Add a comment

1 Answer

Try to disconnect all the flex cable’s except the dockconnector and battery from the logic bord and connect the iphone to itunes for a recovery or update and when th ephone boots up you can connect the flex cable’s one by one so you know which is causing the loop.

Was this answer helpful?

Score 0

Comments:

I ended up ordering a new dock connector for the phone, I'll let you know if your suggestion worked when I get the connector in! Thanks for the advice!

by

Add a comment

Add your answer

Benerang official will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 48