Fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. GSM / 8, 16, or 32 GB capacity / Model A1332 / Black and White.

3140 Questions View all

Why do headphones work, but not inline mic and controls?

Headphones work great, no issues. The in-line mic and volume/skip buttons do not respond at all. When a call comes in when I have headphones w/ mic in, it comes through the headphone but I must speak into the mic on the phone.

I understand there's a contact in the headphone jack that the phone registers when you plug a supported headset in...as far as I can tell, this is not obstructed by lint or anything.

I've tried several different pairs of headphones...the stock iPhone 4 don't work, I tried my friend's stock iPhone 4 headphones, and a 2 different 3rd party pairs...I've ruled out the headphones as the issue.

I replaced the Headphone Jack & Volume Control Cable. This was no easy task, so I was very happy to have everything turn back on and work perfectly, but terribly frustrated when the inline mic and controls still does not work.

What else can I possibly try?

Thanks in advance for any assistance.

Steve

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

8 Answers

Most Helpful Answer

I have a set of Beats by Dre headphones that have worked very well since they were purchased. Today, I have been listening to my music while I work and decided to update my phone to the most recent IOS (v. 9.1). As soon as the update was finished and after exploring what the new IOS has to offer, I re-inserted my headphones to start listening to music once again and am now experiencing the exact same problem that you have mentioned. Prior to updating = no problems. IOS 9.1 = no more control from my headphones. Just like you said; sound still works perfectly but the microphone, volume control and song selector buttons no longer function. I just used my headphones on a co-workers iPhone with IOS 7 and they function perfectly. This is obviously a problem with the latest IOS release from Apple. I know for sure my phone is in perfect condition and now can forsurely say that my headphones are not the problem. Really only leaves one possible reason....

Very annoying to say the least. Apple should be looking into this to figure out a solution. I miss Steve Jobs.

Was this answer helpful?

Score 2

Comments:

I have an iPhone 5S

by

I am also on an iPhone 5S and I'm using a pair of Sennheiser ear buds. Remote stopped working once I "upgraded" to IOS 9.1. I have not found a solution yet. If you have one please share.

by

Often dirt gets into the headphone connection, which limits the headphone jack to be fully inserted. Some headsets may still work, other not. The dirt is pushed all the way to the end by the headset jack. Use a toothpick to get the dirt out. This also happens with the Apple power connector, reducing the connection reliability when charging.

by

Add a comment

I had the same problem - thanks to this thread I tried the toothpick and found a bunch of pocket lint had collected deep in the headphone socket. I cleaned it out and plugged in my phones ... now the controls work perfectly again.

Thanks, internet!

Was this answer helpful?

Score 2

Comments:

I just got a NEW pair of Dr.Beats ear phones and realized the controls weren't working. I did not trust that this would work, and I tried it and now my controls work perfectly. Thanks! :)

by

Same here, sounds obvious but worked a charm. I also had issues with power cables flicking between charging and not. Cleaned some lint out of that in the same way and now that problems resolved too! Yeay (slightly embarrassed at the amount of lint I must create).

by

Add a comment

Is this iPhone under warranty still? Then I would think Apple should repair it for free. Any way I would try to call Apple Suppport.

Was this answer helpful?

Score 1

Comments:

AppleCare expired in June. Also, taking the phone apart to replace the headphone jack requires to remove the warranty sticker on the screw holding the logic board in place; at this point warranty repair is not an option.

by

This seems strange when you have replace volume/headphone cable. Did you try to restore the phones software in iTunes now after the cable change? You did not mention if you had removed the dock connector when replacing the cable but you write that the internal mic works fine. I would try reinstalling. I did this on a iPhone 3GS with unresponsive click on the original headphone and a software restore fixed the click.

I have also read that resetting network settings helped a couple of times. Take a look at this thread, (as I understand it is the mic on the headphones that do not work):

https://discussions.apple.com/message/11...

I know you are out of warranty but if none of this helps I would give ask Apple anyway. This seems to be a bug.

I am glad we have a strong consumer law in Norway as Apple would have to fix this kind of problem up to 5 years after purchase (even without AppleCare).

by

Add a comment

my fix for sound problem w headsets

(note only problem was with headset)

settings

music

volume limit > (tap on this)

moved control from left to right

Fixed!!!

NOTE:

it was set at 0 all the way to left showing a grayed line; moving to right will show a blue line,

(also note! grayed word OFF, to the right of Volume Limit words, keeps there rather Vol limit "up" or "down" L or R)

Was this answer helpful?

Score 1
Add a comment

Try rebooting the phone (full power cycle) and see if the headphones inline controls function returns.

Was this answer helpful?

Score 0
Add a comment

Get a toothpick or something pointy and clear out the lint wedged into the headphone jack socket. Worked for me!

Was this answer helpful?

Score 0
Add a comment

Are you trying to work your head phone with iPhone or Android phone? If it is Android phone it won't work with iPhone headphone. It is described here:

Apple Headphone is Not Working On Android or Windows Phone

Was this answer helpful?

Score 0
Add a comment

Wow thank you... i also did the same thing by cleaning it with the toothpick, and now it works fine

Was this answer helpful?

Score 0
Add a comment

Add your answer

stmyers will be eternally grateful.
View Statistics:

Past 24 Hours: 74

Past 7 Days: 722

Past 30 Days: 2,940

All Time: 66,870