Revamped version of the iPhone 3G with faster processing speeds. Repair of this device is similar to the 3G, and requires simple screwdrivers and prying tools. Model A1303 / 16 or 32 GB capacity / black or white plastic back.

1946 Questions View all

Vibrator not working after housing repair.

I just recently attempted to replace a housing on an iPhone 3GS and now everything works perfectly, but the vibrate/ring switch is not sticking as far out as usual, and the vibrator does not work at all. When I switch the vibrate switch, the screen will show that it is in vibrate or loud mode, but it wont vibrate.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

"If at first you don't succeed, try try again." The fact that your switch wasn't sitting right and that you've have added symptoms after taking apart your phone again suggests that you are not reassembling properly. Go as far into your phone as you did before and make sure EVERYTHING is connected and seated properly. I would also recommend cleaning contacts/connectors while you are in there, it could be as simple as that! Let us know how it goes!

Was this answer helpful?

Score 1

Comments:

Hey thank you so much for the answer, I was so busy that i never really had time to look at it, but it was just a bad battery!

by

Cool! Glad you got it figured out.

by

Add a comment
Most Helpful Answer

Try Settings App>Sounds>Make sure the settings are correct and try to get the Vibrate going here. Reset, hold both Home and Power buttons until the iPhone restarts by itself. See if working. Did you remember to install the vibrate motor? Vibrate motor may have died? Vibrate motor contacts may not be making good contact with bottom of Logic Board? This is a new housing with fit issues already popping up. Good luck.

Was this answer helpful?

Score 1

Comments:

9/10 times it's the vibrate motor contacts..either they're flattened or it's not in properly. make sure the motor covers 2 little tabs are in their holes

by

Well I tried to pull it apart again, and I now it just shows up with the low battery and when i plugged it in it said it was charging the low battery, and it stayed like that all day.

by

Add a comment

Add your answer

Ross will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,723