Skip to main content

SONOS PLAY 5 is the original, bigger room, bigger sound, all-in-one Sonos music player.

36 Questions View all

Sonos Play 5: Gen 1 (Not Powering)

My Sonos Play 5: Gen 1 is great but has unfortunately, stopped working. I’ve checked the fuse in the power connector and it’s fine. I’ve done some research and have realised that there’s actually a glass fuse on the power board inside the speaker which, is what i’m looking to investigate… I don’t know if this problem is popular or not but I have contacted Sonos support and still haven’t gotten a reply so i’m willing to fix it myself. My main questions are;

  1. What could be the problem and am I likely to fix it?
  2. If I take a look inside the speaker am I prone to breaking anything or ruining the factory assembly by taking it apart, e.g. will it ruin the performance of the speaker and will things rattle about?

Please let me know,

Thanks.

Answer this question I have this problem too

Is this a good question?

Score 3
Add a comment

1 Answer

Having looked into a problem like this, I can say there seem to be two main failures that lead to what you see: 1) the rectifier is damaged, which also blows the fuse, and both parts need to be replaced. or 2) those parts aren’t blown and unless you are lucky and have a visibly damaged other part, there isn’t much help (though there does seem to be a theme of pulsing voltages on the DC outputs, there is no root cause or solution known)

Was this answer helpful?

Score 0
Add a comment

Add your answer

Noah Beckman will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 45

All Time: 2,499