Power shuts off when unplugged after battery replacement?

Block Image

It’s all in the title. I replaced my battery manufactured by Newertech with a friend yesterday, and even though we had a hard time connecting the battery into the logic board (it just wasn’t staying connected for some reason), we eventually got everything running. The battery looks healthy on Coconut Battery and the computer runs much better than it did without the battery (we tested it just out of curiosity), which leads me to believe that it is in fact connected to the logic board well enough.

But after unplugging the computer, it just shuts off. It won’t power on without the charger plugged in either. I reset the PRAM and tried to reset the SMC, but it seems like the SMC can’t be reset under these conditions since the cord light is giving me no indication whether the SMC actually reset. I really don’t want to remove the battery and place it back in. Its connector is longer than I expected and is really difficult to cram in. If that’s the solution then so be it. Any suggestions?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Can you post a snapshot of CoconutBattery main window so we can see with the charger plugged in and a second snapshot with it disconnected after waiting a bit (~5 minutes) Adding images to an existing question

by

If I unplug the charger the computer will shut off. Or am I misunderstanding you? I've added a picture for Coconut Battery.

by

Add a comment