Skip to main content

This is the Asus - VivoBook X540SA-BPD0602V 15.6", (1366x768) Laptop which contains an Intel Braswell Quad Core N3700 1.6 GHz processor that supports turbo up to 2.4 GHz. It contains 4GB of RAM and a 500GB hard drive.

15 Questions View all

Urgent help: Wifi is not working!

My wifi is not working from yesterday. Instead of the wifi symbol, there is a symble of ethernet with a red cross sign over it. I tried to update wifi drivers multiple times but it not worked. What can I do now?

Please help!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

The first thing I would do is try replacing the Asus drivers with the vendor reference driver, as that sometimes fixes it by removing the value add garbage that creates these issues. We don’t know what’s in your laptop, but Asus either uses Intel or QCA/Atheros ath9k or 10k for the semi modern machines - it’s usually Atheros outside of the PRO line. Run a copy of Ubuntu or Debian Live Linux and type lspci -nn and you’ll get the chipset to reference the vendor for. Download that on another computer and scrap the Asus driver first. You may want to use Non-Free just in case. ath is Atheros and Intel XXXX is Intel.

If that doesn’t fix it, you need to change the card. It’s pretty complicated on this since the thing needs to be gutted to do *anything* to it. Refer to this guide to get the palmrest off and change the card. Get an Intel 7260AC off of eBay that’s NOS (plenty left despite being EOL’d) or an ath10k AC card. AX is nice, but most routers do not support it and by the time you get an AX router, it’s going to be obsolete anyway - save your money and get a AC card. You may not even be able to *buy* a standard card and it may be NGFF only, which this lacks.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Sushanto Kumar Saha will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 60