iPhone 3G

Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1461 Questions View all

Phone will not power on

I have an iphone 3g that will not power on. when i plug it in to AC power the Apple Logo appears for a fe wseconds and then goes off. someone told me that i might need to replace a green jumper on the logic board, i have searched an have not found anything referencing this online. Also where can i get schematics for the iPhones.

any help will be greatly appreciated.

thank you

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

thank you, i will start there and hope that is all it needs.

by larry

I'd go with what oldturkey says before looking in to green jumpers..what you have written sounds just like a bad battery. As oldturkey says it's near the end of it's life, replace that and see what happens.

by pollytintop

I have replaced the battery and it is still doing the same thing. Apple icon will appear then disappear.

by larry

larry, here is the schematic http://www.keepandshare.com/doc/3112813/... Have you tried to restore your phone? Have you tried DFU yet?

by oldturkey03

Add a comment

1 Answer

Chosen Solution

larry, I would think just by the brief description that you need a new battery. It is possible that your battery is at the end of its lifespan and does not hold a charge. Start there and reevaluate.

UPDATE

check your fuses as well

iPhone 3G Replacement Battery

iPhone 3G Battery Replacement

Block Image

Block Image

Mentioned Items

Was this answer helpful?

Score 4

Comments:

I have replaced the battery and it is still doing the same thing. Apple icon will appear then disappear.

by larry

first I'd try checking all your connections to the battery and the output of your battery..it needs to be 3.7mAh on a full battery and over ?2.6mAh to take a charge. try a restore in itunes and see what error code you get...let us know. also try iReb or tinyumbrella to get out of boot loop. this may have nothing to do with any fuses..if you installed a new fully charged battery then the phone should have worked until the battery went dead. This may be a problem with your power ic.

by pollytintop

Add a comment

Add your answer

larry will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 1,663