My iPod only works when its charging.

My iPod 4th generation nano only works when plugged in. I have left it plugged into ac power overnight, and in the morning it shows it's complete, but when I unplug it, the screen goes dark and the device loses power. When I try to turn it on by holding the play button nothing happens, I try to reset it by holding the menu and center button for 6-30 seconds and also nothing happens. The device was used rarely from purchase and has been sitting without a charge for at least a year. I can listen to music while it's plugged in and "charging" but when I disconnect it from the ac power cord its a dead duck. If anyone can help me I'd be greatful.

Answer this question I have this problem too

Is this a good question?

Score 10
Add a comment
Black Friday
Broken doesn't stand a chance.

7 Answers

Most Helpful Answer

Reboot it while it is plugged in. That's what i did and it worked.

Was this answer helpful?

Score 4

Comments:

How u did this bro

by

Hold the Menu and select buttons at the same time for 8 seconds or until it turns off. Once you see the apple logo, it's been rebooted.

by

thanks was about to throw it in the trash back to normal ;)

by

Add a comment

Hey Ryan, sorry to hear about your Nano. Sounds like a dead battery to me. Your best bet would probably be to replace the battery with one of our battery replacement kits. Unfortunately, replacing the battery requires some soldering, but if you're game, give it a shot! What better way to learn, right?

Hope this helps! Good luck, and let us know how it goes.

Was this answer helpful?

Score 1

Comments:

and this is a hard fix..i gave up and sent mine to oldturkey!well done nick

by

I had the exact same issue - probably used the thing less than 10 times since I bought it, and when I pulled it back out to take a trip last week, it wouldn't charge. It really chaps me as it's still in like-new condition and was certainly not worn out! And Apple wants something like $60 to replace the battery, what a scam...

by

Add a comment

hey im having the same problem but it looks like it has water inside when i never had it near water i was charging it on my computer then i put it away in my drawer i dont get it and it would only turn on when its plugged

Was this answer helpful?

Score 0

Comments:

that would mean that you for sure have a dead battery.

by

got the exact same problem

by

Add a comment

I just took my iPod 4th gen apart and there was corrosion on the board so I figured I may as well clean it. Will update when I see what happens!

Was this answer helpful?

Score 0
Add a comment

Block Image

Was this answer helpful?

Score 0
Add a comment

I am having the same exact problem with my ipod nano touch 6th Gen...

Was this answer helpful?

Score 0
Add a comment

i ready did that (Battery Replacement),but still the same issue prevails.!!! HELP !!!

Was this answer helpful?

Score 0
Add a comment

Add your answer

Ryan will be eternally grateful.
View Statistics:

Past 24 Hours: 27

Past 7 Days: 197

Past 30 Days: 893

All Time: 38,780