Model A1312 / Mid 2010 / 3.2 GHz Core i3 or 2.8 & 3.6 GHz Core i5 or 2.93 GHz Core i7

232 Questions View all

SSD Drive not showing up in Disk Utility

I had an OWC SSD drive installed a couple of months ago which had been working great. I installed OS X Lion on it a couple of weeks ago. Two days ago, after I woke my computer from sleep, the system locked up and quit responding. When I rebooted I got the flashing folder of death. I booted off of a recovery thumb drive and ran Disk Utility thinking it was perhaps a user library folder issue. When I open Disk Utility my SSD drive no longer shows up in the list of available disks. I can see my attached drives and my original 1 TB internal HDD, however the SDD is no where to be found. Is there as way to recover the SDD without tearing my iMac apart and physically removing the disk to test it? I need help as I am now stationed in Korea and a mac service center is nowhere close.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

It seems you have a big problem with your failed SSD. You can download a demo version of DataRescue from here: http://www.prosofteng.com/downloads/

- that will give you an idea of if it is possible to rescue data. The demo version scans your disk like the buy version but does not allow you to recover data. Good luck!

Was this answer helpful?

Score 0
Add a comment

I used DataRescue and it does not even list the drive as available. I also booted a DVD version of Linux and the drive does not show up. I am thinking it is a critical failure and my SSD is bricked.

Was this answer helpful?

Score 0

Comments:

Well, it seems you are in trouble if DataRescue does not find anything. You still have guarantee on that SSD so you should contact OWC. But your data on the SSD seems to be lost if you don't have a backup.

by

Add a comment

Have you managed to find a solution to this?

I am having the same problem on my 27" iMac so I tried another SSD and had the same problem, I then opened up my mac for a second time and tried the original 1TB drive, that worked fine!

This all happened after an apple update the night before.

So have they disabled the BIOS recognizing 'non-apple' drives?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Andrew Lawrence will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 12

Past 30 Days: 56

All Time: 3,075