My headphone jack isn't working

I've used different kinds of headphones and it still doesn't work. I need help!

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

Same thing happened to mine after it was tossed (by someone else) and hit the headboard of my bed. I can still get audio without headphones, but with headphones-- Nothing.

The headphone jack is soldered to the logic board instead of it being a separate piece like earlier iPod models. And so, in order to replace the head phone jack in the iPod touch, you have to replace the entire logic board.

Try backing up your iPod with iTunes and then restore it to that back-up copy. If it starts working, it maybe a software issue on the iPod touch. If that does not work, you can always try restoring it as if it is a new iPod, but then you would loose all your data and settings on the iPod... But it is still worth a shot.

Was this answer helpful?

Score 1
Add a comment

Check to see if you have a broken tip inside the headphone jack.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Bradley will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 5,392